Worldwide routable Garmin maps: URL REMOVED

I’m only a novice on all the tricky bits about Garmin maps, but I do know that by using JaVaWa GMTK, I can easily change the family ID - but that is for files on the computer viewed with MapSource and BaseCamp. (Not sure whether it’s going to help if you’re just getting img files to stick directly on an SD card.)

Hi there. I have tried on a few occasions to receive an email with my manually selected tiles for the past two weeks. I am following the onemanengine instructions to the letter. routeable bicycle etc. This has worked for me in the past. My email address is correct (Hotmail) and I have also tried another email address. I get the webpage opening tell me I’m X in the queue.

Any help greatly appreciated.



The service does work, have you checked to see if the download email has been diverted to your junk or spam email folder on your PC. Failing that check your Hotmail account online.
Regards Bernard.

Hello Guys!

If am facing a small but frustrating issue: I need to use bigger maps that 2Gigs, travelling accross Eurpe. I am planning my trips in mapsource/basecamp but cannot install both windows maps, as the name of the application (OSM Generic routable) is the same for both, and the installer says it’s already installed.

I would by nice to have some generated or user input unique ids in the installer/application name.

Can I fix that somehow, or can you develop a feature like that?

Thanks! :slight_smile:

Further experimenting shows that although the paths render as dark lines in MapSource or BaseCamp, if they are then downloaded to the GPS using MapInstall, they render as white lines (same as if the .img version of the map was loaded directly to the SD card).


question about course routing using Garmin Edge (Edge 830 in my case) devices.
Checking all possibilities, but routing for MTB bike uses mostly main roads. Any clue how to make the routing usable for MTB bike using the OSM downloaded maps?

The solution to my problem has been to switch to the “Generic Routable (new style)” maps, which show the paths in dark lines.

The Windows to Basecamp exe installer file is designated as dangerous by Windows and is blocked from reception to execution. What can be done? I want to examine the Map in Basecamp before I trial it on my Touch 35 device.

You can use the (not only for Mac OSX but also for Windows)
Unzip it and place the .gmap folder to the default Garmin map folder. Default map folder is C:\ProgramData\GARMIN\Maps or C:\Users{user}\AppData\Roaming\GARMIN\Maps (please note this is a hidden folder!). Or you can use to install the gmap maps.

Hello, how can I download a nautical map, since I do not check the option, thank you.

That option does not work, I dont know why it is even there.
Better search on a different site,

Just go ahead and install it.

It seems the “Generic routable (new style)” is not incorporating new OSM data. I have been downloading and downloading over the last few weeks waiting for changes I made to be visible in the downloaded maps. In frustration, I finally downloaded a “Generic routable” version (ie not “new style”) and all the changes were there!

This is bad news for me because using the “new style” was my solution to the plain “Generic routable” type now rendering paths as (usually invisible) white lines.

Yes, I think there is something broken during map compilation, please report it directly to Lambertus the owner of that site, as he won’t read this forum: osm at na1400 dot info

Good morning, I wanted to know what possibilities there are to modify for Argentina because if one needs to look for an address where it is the autonomous city of Buenos Aires, it appears in English and by commune, which makes it difficult to find addresses and streets. The idea would be to replace autonomous city by city of buenos aires thank you very much sorry I’m using a translator


Hi there,

I do not know if the following has been talked about already, so sorry if it has. I just installed the OSM Routable map for Portugal onto my Montana 610 and the other evening when I turned it on (after sunset) instead of a completely dark map, it came up in black (for the buildings I think) and the rest white! I thought at first it was the unit playing up, but then I enabled the Garmin City Nav map and all was as it should be. Don’t the OSM maps have a working “night” function?

One more thing, the following message has popped up in JaVaWa Device Manager: Error: segment codes from this file reside in other files. This will cause problems with routing and/or displaying maps.

Thanks in advance,


Site is since a few days, hope it will be up again soon.
I now see how I need and miss this site… so I won’t forget to donate as soon it’s back, hope you guys will consider too.

Hello! Quick question.

I have a Garmin 520 (no expandable storage), so I always choose as few tiles as possible when downloading new maps. But recently, when I select my state (in the US), I can’t de-select the tiles I don’t want…and the map is too large for my GPS.

There used to be an option to select the tiles you wanted manually, but now it’s been replaced with “perhaps you’d like to select more tiles” and an option to reset your selection.

Any tips on what I’m doing wrong? Thanks so much!

I am a Garmin 520 user and so can only download a few tiles at a time for them. As the servers are down at the moment I only have the option to download all of France which my Garmin doesn’t have the memory for. When will the servers be back up and running like normal so i can download just a few of the France tiles that I need.