Worldwide routable Garmin maps: URL REMOVED

**UPDATE BY ADMIN 3 May 2022: THE SITE NO LONGER WORKS. List of alternatives: **

Request to all users: Please download only what you really need, so other users can enjoy this service as well. Thank you.

The goal is to make routable OpenStreetMap Garmin maps at least as easy to install and use as commercial and other map providers. I’m aiming for worldwide coverage on and hope to update these each week. This service allows you to download specific tiles directly or to combine a selection of maps into an installer for MapSource and Roadtrip or as a gmapsupp.img for direct placement on your GPS device.

If you wish the server to build a combined map for you then you can enter your e-mail address and click the ‘Combine tiles’ button. The server will then start working on your request and send you an e-mail with the download locations when finished. This e-mail address is only stored while the server is busy handling your request and deleted after the confirmation e-mail is sent. I will not use your e-mail address for anything else.

Predefined countries
If the country of your interest is listed in the dropdown box then I suggest you use only the dropdown box to select the tiles. Tile combination’s that are requested more then once will be delivered from the cache and thus much faster then unique requests.

Address search
To use the address search you must:

  • Enter any housenumber first (it does not have to be an existing housenumber)
  • Enter the streetname (at which point the GPS will start providing feedback about possible matches). You can choose the street from the matches or
  • Enter the placename to narrow the search down to the correct street.

If your GPS device asks for a State/Country code then don’t use the address search but use the following two-step process:

  • Search for the city/place name. Select it.
  • Search for the street name. Select it.


  • Because of the default style for Mkgmap to be focussed on car routing, these maps work best for car routing. Short bicycle and foot routes work fine though in general.
  • A tile limit is enforced because reality showed that too many people are greedy and request excessive amounts of tiles which causes other requests to suffer from long waiting times and huge bandwidth usage. I see little reason why anyone would need the entire world as Garmin map. I’m sorry if this causes some inconvenience.

Known problems

  • Looking up addresses does not work very well. Not much I can do about it. Other map providers using the Mkgmap tool suffer from this as well. I’m sure this will improve in the future.
  • The ‘Find Places’ option in MapSource does not work well either. It is related to the previous issue. Use the same two-step search approach as described earlier.
  • Oceans and other very large areas of water are not being rendered, so you won’t see them. This will improve in the future.
  • When someone requests one or more non-existing tiles (the red ones) then the RoadTrip installer build script will most likely fail, so don’t choose red tiles if you care about MacOSX and RoadTrip.

You can get contact me by replying to this forum topic, using the email function of this forum, through the OpenStreetMap user page or by email at: osm at na1400 dot info

Lambertus, thank you for your efforts. Without having read your second posting, I tried to create a combined dataset and here are my experiences so far:

  • The confirmation e-mail is detected as Spam. Maybe you should give it a more personal touch.:slight_smile:
  • My mail program (Alpine) was not able to correctly decode the URL for the MapSource installer. You should replace the blanks by underscores.
  • I couldn’t download the MapSource installer, but as you mention it might not be there despite the URL.

I just downloaded the gmapsupp and will try that tonight on my c510.

Thanks for your comments.

I noticed the spam notification too. The email contains a lot of URLs so I guess that’s a red flag. I will try to add a lot of extra text about OSM and my service to see if it helps.

The URL for the MapSource installer is fixed. It’s working now for me.

these are IMG files , I was looking for Mapsource files.

If you select the images you want, enter your email address and click the ‘combine maps’ button then the server will create the MapSource installer (among other things) for you and e-mail you with directions where you can download this installer.

I didn’t try it because I lacked the time to hook up the c510 to the computer. I tried the MapSource version however.

Download is OK, but the installer doesn’t write the correct registry entries. I could see the maps with MapsetToolkit but not in MapSource’s selection menu. So I deleted the bad entries with MapsetToolkit and pointed it to the correct location. That worked.

Can you remember which entries you changed?

No, I just used MapsetToolkit for the installation.

New changes:

  • I just created a new set of maps thanks to user Skinkie who used a server at the center for math and computer science in Amsterdam (CWI) to split the tiles again with a slightly different parameter. So this time there are fewer tiles that failed to render. I also changed the Mkgmap commandline so I hope the maps will install correctly this time (I will check later).

  • The KML file, that defines the areas as you see them on the map, is now fetched using a PHP script instead of fetching it directly from the server. This will hopefully stop the browser to persistently cache the KML file even when it changed (You’d needed to clear the cache before a new version would be displayed).

  • The KML file now automatically updated with the information to show if a map file is present on the server or not.

I think I fixed the installer bug for MapSource.

Now MapSource crashes on start. Your installation might not be compatible to version 6.15.3?

The installer should be compatible, it probably because of the remnants from the old installer that cause it to crash. To clean the registry delete the following registry keys:




Then reinstall the routable map only if you’ve requested the map after yesterday 12:00 CET. Otherwise let the service generate a new installer.

The registry then should contain the following key and values:

LOC=[installation directory]
BMAP=[installation directory]\63240000.img
TDB=[installation directory]\63240000.tdb

If your registry contains these values then MapSource should without crashing.

No, everything looks as you describe but still MapSource crashes. When I uninstall the OSM maps it is working again as expected. Strange.

If you remove all the osm maps from the registry (under the MapSource\Products) tree and then install only the routable map, what happens then? And can you post the download link you received in the email?

There are no other OSM maps in the registry. The link was

Ok, I found the error and corrected it. Next time you place a new request it will combine correctly for MapSource. Thanks for the report! Note: it worked already fine with MapSource versions older then 6.14.1 but not in newer versions.

I also changed the notification email so that it contains less links in an attempt to avoid it being interpreted as spam.

Install now works perfectly for mapsource 6.15.4.

Thanks so much for providing this excellent service!

While I haven’t used the installer you refer to above. (I use cgpsmapper.) A common cause of MapSource crashes is a corrupted or missing basemap.img or basemap.tdb file. It’s always a good idea to save a “last good copy” of those files. When MapSource crashes restoring those files usually sets things right.

In this case there were two bugs:

  1. a mismatch between the product-id in the individual tiles and the registry key
  2. the installer inserted two of the three values in the correct registry key, but one was inserted into the wrong key. Copy/paste error.

But the installer is running fine now.

Well, people seem to have found the service now, and a significant number of the users have a peculiar interest in downloading almost every tile available. Each one requesting around 900 to 1000 MB which resulted in a disk full situation :smiley:

If all those heavy users just requested all the tiles then the caching mechanism would spring into action and this wouldn’t happen, but it seems like most requests are just a little bit different then others so a new combination has to be created and as a result slowly eating all the diskspace… Maybe I should create one download containing all the available tiles and redirect everyone who requests more then (say) 70% of the available tiles to that one…

But, it’s fun to watch all those requests being made and hope everyone enjoys it too.

Update: The requests are queuing nicely on the server now, so it’s possible you’ll have to wait a few hours. The 70% rule is now implemented, so things might speedup a little in the coming hours as the largest requests don’t need to be rendered anymore.