Worldwide routable Garmin maps: URL REMOVED

You can use the (not only for Mac OSX but also for Windows)
Unzip it and place the .gmap folder to the default Garmin map folder. Default map folder is C:\ProgramData\GARMIN\Maps or C:\Users{user}\AppData\Roaming\GARMIN\Maps (please note this is a hidden folder!). Or you can use to install the gmap maps.

Hello, how can I download a nautical map, since I do not check the option, thank you.

That option does not work, I dont know why it is even there.
Better search on a different site,

Just go ahead and install it.

It seems the “Generic routable (new style)” is not incorporating new OSM data. I have been downloading and downloading over the last few weeks waiting for changes I made to be visible in the downloaded maps. In frustration, I finally downloaded a “Generic routable” version (ie not “new style”) and all the changes were there!

This is bad news for me because using the “new style” was my solution to the plain “Generic routable” type now rendering paths as (usually invisible) white lines.

Yes, I think there is something broken during map compilation, please report it directly to Lambertus the owner of that site, as he won’t read this forum: osm at na1400 dot info

Good morning, I wanted to know what possibilities there are to modify for Argentina because if one needs to look for an address where it is the autonomous city of Buenos Aires, it appears in English and by commune, which makes it difficult to find addresses and streets. The idea would be to replace autonomous city by city of buenos aires thank you very much sorry I’m using a translator


Hi there,

I do not know if the following has been talked about already, so sorry if it has. I just installed the OSM Routable map for Portugal onto my Montana 610 and the other evening when I turned it on (after sunset) instead of a completely dark map, it came up in black (for the buildings I think) and the rest white! I thought at first it was the unit playing up, but then I enabled the Garmin City Nav map and all was as it should be. Don’t the OSM maps have a working “night” function?

One more thing, the following message has popped up in JaVaWa Device Manager: Error: segment codes from this file reside in other files. This will cause problems with routing and/or displaying maps.

Thanks in advance,


Site is since a few days, hope it will be up again soon.
I now see how I need and miss this site… so I won’t forget to donate as soon it’s back, hope you guys will consider too.

Hello! Quick question.

I have a Garmin 520 (no expandable storage), so I always choose as few tiles as possible when downloading new maps. But recently, when I select my state (in the US), I can’t de-select the tiles I don’t want…and the map is too large for my GPS.

There used to be an option to select the tiles you wanted manually, but now it’s been replaced with “perhaps you’d like to select more tiles” and an option to reset your selection.

Any tips on what I’m doing wrong? Thanks so much!

I am a Garmin 520 user and so can only download a few tiles at a time for them. As the servers are down at the moment I only have the option to download all of France which my Garmin doesn’t have the memory for. When will the servers be back up and running like normal so i can download just a few of the France tiles that I need.

For some weeks it is not possible to download a part of for example France. Now I dedided to download then the map of the complete country, but unfortunately the download will not start. Does somebody know when this will work again?

Pick a site which works for you from here

Hi so I’m trying to get a map on to my GARMIN 520, it was always easy with but now that’s not working I’m having trouble.

So I download the map I want from (it’s only a small map so storage, isn’t an issue)

I’ve tried the options Garmin cycle and Garmin openfietsmap both LATIN AND UTF-8

Then I just drag the image file to the GARMIN device folder and rename to gmapbmap.img (I deleted the old file already)

But I haven’t managed to get a map image to display on the device.

Is there any step I’m missing or something anyone can see that I’m doing wrong… thanks!

Don’t delete gmapbmap.img - this is the background map that your garmin needs, it is essential and should never be deleted! Just copy the gmapsupp.img to the garmin device folder was all you had to do, maybe rename it to anything.img but gmapbmap.

Hi there,
I have a problem with copying the OSM that has been already installed in Basecamp to the Garmin 60csx. Even though the map is detailed in the Basecamp and working properly, the program copies it in such a way that only highways and lakes are visible on the device (on a white background for this area).

I‘m using that way (from Basecamp to Garmin) to copy tiles because I do not have the gmapsupp.img file of this area anymore and I cannot download it anymore because doesn‘t work (only whole countries are available).

Does anyone have any idea why I cannot copy this map? As I said, I have the whole map but not in the single .img file. Maybe there is a way to make it.

Thank you for your help.

Thanks for the help but this was the guide I used before and it worked, I just cant figure out waht I;m doing wrong…

  1. Download the map section of interest per the ‘Part 1: Downloading the Maps’ section (again for the Edge 520, remember to keep it small*: See note at end of this section!).
  2. Plug-in your Garmin Edge 520 to your computer.
  3. Within the \Garmin folder on the Edge 520, you’ll find the gmapbmap.img file (Disc Image File). Make a backup copy of this on your computer for long-term safe keeping.
  4. Within the \Garmin folder on the Edge 520, delete the gmapbmap.img file (after you’ve copied it elsewhere). Note: If on a Mac, you must now empty your Trash bin, otherwise you won’t reclaim the free space. This is not required on Windows.
  5. Copy the gmapsupp.img map file you downloaded into the \Garmin folder on your Edge 520.
  6. On the Edge 520, rename that map file gmapsupp.img to gmapbmap.img – don’t worry if you can’t see the .IMG extension, just rename it to gmapbmap, like below.

Oh ok, maybe because the disk space on the Edge 520 is so small that it will only contain the basemap.
I have no idea why it won’t work anymore, sorry.

Hello Everybody!

Since I have not really found the answer, here my question:

Does anyone know how often the maps generated on “” are synced to OSM?

Just asking because I have found a lot of errors around here where I live (Central Mississippi, USA), such as unconnected roads that actually are connected and such) and have made the appropriate edits to OSM. There those roads are ok now, but I use the maps for my Garmin, and my edits are not reflected there, even those made months ago…