The latest GMAPSUPP.IMG for Ontario, Canada causes problems

Both the generic routable and routable for 2017-11-23 cause my Garmin Nuvi 56LM to crash and shutdown when I include the GMAPSUPP.IMG files from either on the microSD card. This is for the Garmin OSM for Ontario, Canada. When I revert to the internally stored GMAPSUPP.IMG, everything works fine and routing is fully functional. When I try to choose a route with the Garmin OSM map, the GPS completely shuts down when trying to build the route.

Workaround for now is to use the internal GMAPSUPP.IMG despite the fact it is really outdated right from Garmin.

Any suggestions for solutions would be greatly appreciated.

You can try to create a gmapsupp with Basecamp’s Mapinstall or Mapsource instead of the premade version?

LIGFIETSER - That seems to have worked. I created a gmapsupp file for Ontario, Canada from an extracted OSM file and it worked ok in my Garmin Nuvi 56LM. So question… when I download the next updated file from Garmin OSM, will it still be corrupted and cause my GPS to crash, or will it be corrected ?

Glad to hear this workaround solves your issue. Because the gmapsupp is generated with experimental software (mkgmap) it is very likely that next updates also cause crashes I’m afraid.

Apparently, Mapsource or Basecamp can filter those glitches out of the map when writing the data to your device. Unfortunately Garmin will not reveal its source code so the mkgmap engineers have to programm those maps by trial and error so it is unknown when or if those errors can be fixed.

UPDATE: I just tried the updated GMAPSUPP downloaded file from Garmin OSM for Ontario, Canada and it caused my Garmin NUVI 56LM to crash again. So, now I either use the internal GMAPSUPP file as supplied quarterly by Garmin, or I use the convoluted process as outlined by LIGFIETSER to create my own GMAPSUPP files from OSM using splitter/mkgmap. I have no idea what changes have been made within Garmin OSM but the previous useable GMAPSUPP download file is no longer available for my Garmin NUVI 56LM.

Hi Ligfietser,
if I got that right mkgmap produces a gmapsupp that is incorrect. I think this should be corrected. Do you know the parameters used to create the tiles and to create the gmapsupp?

Hi Gerd, the parameters that Lambertus uses are here:
I don’t know how he splitted the tiles.

LIGFIETSER - to further detail the problem with the GMAPSUPP generated by Garmin OSM for my Nuvi 56LM, it has something to do with routing, because the map itself does not cause the gps to crash, it’s when it tries to calculate a route when it crashes. The map itself is viewable and useable by the gps and does not cause it to crash.

Todd, which map does not crash, you’ve mentioned the one that you have compiled yourself with mkgmap. How about one that you have send from the pc to your device with Basecamp’s Mapinstall?

LIGFIETSER - I followed the directions as outlined in
and the resultant GMAPSUPP worked ok in my gps. The one downloaded directly from Garmin OSM causes the gps to shutdown when I try to route. I have not done anything related to Basecamp. I hope this helps.

Todd, does that mean that your device crashed with a map published by Garmin? Or what is meant by "The one downloaded directly from Garmin OSM "? Maybe you have a link?

Gerd, he mentioned generic routable and routable from Lambertus.
Todd, you could also install those maps on your computer and let Basecamp generate and send the maps to your device. Did you try that too?

OK, I just tried a GMAPSUPP created from Basecamp with the latest Windows install from OSM and my Nuvi 56LM still crashed when I tried routing.
So let me try to clear up definitions…
The quarterly map that I get right from Garmin to the internal map on the Nuvi of course works fine.
The Garmin OSM download that I refer to is the one from and the downloaded GMAPSUPP that I copy to the microSD card in my GPS is the one that causes the gps to crash when I select that map and route with it. Also, now I know that the downloaded file that is used to update the Basecamp map and then produce a GMAPSUPP file on the microSD card by using the Basecamp Mapinstall also causes the gps to crash.
Besides the internal Garmin map, the only other one that still works is the GMAPSUPP that I created following the procedure as outlined in which also uses data provided by an OSM extract and then produces a GMAPSUPP file using the detailed and time-consuming process of running splitter/mkgmap on my computer.
So, I hope this clears up all the details.
The bottom line is the files from Garmin OSM from no longer work with my Nuvi 56LM.

Since this version is from a certain extraction date and the one that you have compiled yourself with the same software (mkgmap) works without issues, I could imagine that a next update will work, if the cause was a bug in the OSM data?

So you can keep an eye on the coming updates, or keep generating those maps yourself, because then you have always the latest OSM data.

I just tried the Garmin OSM map of Ontario posted 31/01/18 and it once again works with my Garmin NUVI 56LM and doesn’t cause it to crash. So whatever was doing it before has been fixed and/or removed. Thanks.

Here we go again. The latest GMAPSUPP.IMG dated 22/02/2018 once again causes my NUVI 56LM to crash when I route to a destination. It is OK if I am just viewing the map. Something is causing this when the IMG file gets created.

Hi Todd,

please provide more details. Is it a special route that causes the crash? from where to where?
The last time that I looked at this area it was full of problems regarding mapping of ferry routes.
Those problems caused large detours in Basecamp/Mapsource because ferries were ignored and
may be the reason for the crashes as well.


Gerd, all the previous postings give all the details you require. As far as the route used with my GPS, it was just a local routing from my house to our local post office just to test the problem I am having. Everything else as posted in the previous posting still apply.

Can you clarify whether it crashes for any routing, or just when trying to route in a specific area? I can’t see any details about that in this discussion.

Alester, I normally only travel within a 100 km radius of my home but any routing to destinations I have cause the GPS to crash.