Standard carto not updating?

Is it just me, or is standard carto not updating today (2020-04-07)? Ir had a few hiccoughs yesterday, but got over them. Today I made an update 6 hours ago but it’s not shown up yet. That update has shown up on the humanitarian layer, as have a few I did an hour ago. Nothing on the standard layer.

I’m in the UK, if that lets somebody guess which server is giving me stale tiles.

Same in NL. This morning one of my edits was rendered at zoom level 19, everything after that has not been updated.

Same in East Asia for the past few days.

There’s an ongoing process to reduce access to freeloaders - see e.g. et al.

In the short term I’d suggest using a different tile layer - either one of the other 3 at or somewhere else altogether.

Ummm, if I understand the diffs correctly (probably not), the new blocks shouldn’t affect me. I don’t match the blocked domains and my user-agent doesn’t identify as any of the blocked ones.

Only Humanitarian is updated relatively frequently (maybe hourly or so). And even that isn’t updating all the zooms at the same frequency - a change I made 15 hours ago is showing up at z=18 but not z=19.

Also, I’m not blocked from seeing any tiles (which I think your github issue referred to). What’s going astray seems to be tile generation in response to db changes. Stale tiles rather than no tiles.

Sorry - I should have been clearer. The blocks that are being introduced are enforcing the existing tile usage policy. The idea is that with fewer people abusing the tile servers there will be more capacity available for people who aren’t abusing it and are using it exactly for what it was designed to be used for, like you.

And it’s working. It’s serving me stale tiles much faster than it used to. :smiley:

More seriously, it looks like the problem is real and not something I’m imagining. I’m now wondering if it’s being worked on or if the server admins are blissfully unaware.


The renderer was already producing strange results before the ‘lockdown’ happened.

Let’s say that I made edits A through D and pressed Ctrl-F5 in between. It could look like this:

A_old - B_new
A_new - B_old - C_new
A_old - B_new - C_old - D_new

It is not surpising if this takes longer to process. :wink:

So will (my|the) edits ever be added? I’m new, made a few simple changes via iD. Now I don’t know what to do, other than take the advice above. Thank you!

Yes, they already have been. Other maps that can apply updates quicker will show them before the “standard” tiles at will. If you want to be sure that things are “really there” either go into the editor again or zoom right in and click the “data” tickbox at the right-hand-side of You’ll see blue lines corresponding to what you have added. Make sure you turn “data” off before zooming out, though.

More generally, if anyone who wants to see an updated map says where in the world they are, people may be able to recommend a map that will be updated for that area. There’s a long list at

Seeing the same thing. Just tried manually marking a tile as needing re-rendering and it promptly got updated (that single tile at a zoom level).

So I wonder if it’s the process that works out which tiles need to be re-rendered from each edit that has stopped for the last 2-3 days, and the actual re-rendering process is just sitting there happily doing nothing.

How can that be done?


Think the right-click action has been overridden on to give a context menu since those instructions.

The commands will vary between browsers, for me on Firefox (on Linux), I can view the map at the required location and zoom level, then select from the browser menu: Tools-Page Info.

In the box that appears, switch to the Media tab, and scroll through the entries with type=Image of the form (where S is one of the tile servers a,b or c, Z is the zoom level, X+Y are position indexes.

Once you have a tile that you know is out of date, right-click + Copy the URL, paste into a new tab on your browser and press enter if required. You should see the single tile with this URL. Now edit the URL to add “/dirty” on the end, no spaces or quotes so that it ends .png/dirty and press enter. The screen display should change to show the message “Tile submitted for rendering”. You can close this tab, and the Page Info panel. Wait a bit and refresh the map - noting this only applies to the single zoom level tile you selected.

Yep, several tiles I’ve editted days ago are still not rendering the updates (and it’s not a cache issue - I’ve used multiple devices and also cleared cache).

Edit: UK

The /dirty trick - exactly as described in #15 - hasn’t worked for me in a while. I’ve even tried 3x for a., b., and c.tile.etc/dirty, then wait, then force a reload. Nope. Guess it just takes patience.

Lately I’m surprised to see the cycle map updating before the standard carto. Never thought I’d see that. :slight_smile:

@Cebderby, I found your post very interesting.
I am on a Windows machine. I have Chrome and Edge installed. After reading your post, I installed FF.
For the life of me, I cannot find a “Tools” menu!
I scoured the the “three bars” menu, with no luck.
Wonder if you, or someone else, would know how to get tile info on a Windows machine.
Thank you in advance, Eric

In Firefox click the hamburger menu in the upper right corner,
select Customize… (paintbrush),
check the box ‘Title bar’ in the lower left corner.
Now you have the Title Bar in the uppermost row, among which is ‘Tools’
Hope this helps you?

Can’t find “Tools”? No worries.

Since you’ve installed FireFox… On the OSM map page in FF, right-click a blank part of the page, eg left of “GPS Traces”. From that menu, select View Page Info.

Then follow instructions in #15. But as I’ve noted, it may not produce results. Good luck.