Standard carto not updating?

@EricJRW, try right-click in the top area of the browser window eg in the blank space alongside the tab(s) and ‘+’. On that right-click menu, you may have the option to enable “Menu Bar”, which contains the ‘traditional’ menu items File,Edit,View,History,Bookmarks,Tools,Help.

Normally this /dirty trick does little as slow updates are more usually the re-render process getting behind on one or more of the a. b. or c. tile servers, so the tiles are already marked and in a backlog queue. In conjunction with the corresponding browser caches this means there are 6 sources each tile (at each zoom) can come from, which can result in the patchy and or apparently backwards updating sometimes experienced. Only times I’ve used it normally are to encourage an update of an (normally infrequent) zoom 13 tile eg if a big road has been opened or a large construction site added or similar.

Thank you all!
Tried @BikePC 's idea. Didn’t work.
Got to Viajero Perdido, and that worked…
Which is also what @Cebderby suggested!

So now I know how to find tiles! Yay!

Going to try to force an update…

But thank you all.

Learning something new is such fun!

Thank you. Going to try

I use to display the map. Each tile is then directly accessible (right click - view image in Firefox). And then I just append “/dirty”.

May be happening again at the moment.

Pretty sure something is wrong. This changeset which was made 2 days ago is only showing up at zoom level 13.

A request to re-render also doesn’t seem to solve the issue. For instance, the status of this tile is:

But it doesn’t show the current situation (modified yesterday).

I’m having some success marking tiles as dirty via HTTP, but that’s not a scalable solution. It does look like changes aren’t being picked up for some days now.

Hi all,
Just want to add that I am also experiencing the same problems, and have been for a few weeks now.
This is a major problem, as I cannot “check” my edits to make sure everything is alright, and has prevented me from being able to do any editing beyond very small things.

This website:

Is a good one for tile dirtying. To dirty tiles click the + and turn off the two overlay layers,
then simply right click, and open image in new tab then add /dirty to the url (and /status to view the status).

(Also no search function, but you can use permalink to make it easier to navigate).

The manual dirtying has not been working for me given that the server seems to be behind on rendering.
(Note also: there used to be a greasemonkey script for Firefox (which stopped working after a Firefox update), there might be something similar somewhere for tile dirtying).

These are good webpages to see how the server is tracking.

Is there not a non-OSM-hosted server anywhere (perhaps more local to you) that doesn’t have dozens of taxi apps trying to freeload off it as well (as the tiles at have)? The tiles at are usually a good bet. Also what about the other layers at - I know that the two Thunderforest layers don’t update instantaneously, but what about the other two?

Alternatively, (assuming you’re in Australia - apologies if I’m confusing you with someone else) a tile server to handle all of Asutralia + Oceania is well within “desktop PC” range as suggested by the data size at . Various options are available (see, and enabling automatic updates is pretty easy too - see among others.

I also experience heavy lags in refreshing standard layer, you should probably report it here:

This was dealt with yesterday - see