Problems Entering "State/Province" Name on Garmin nuvi 200


Today, I just installed new OSM maps (via on my old Garmin nuvi 200 GPS unit. The unit itself has the latest software version (5.00) and I used MapSource 6.16.2.

Everything seems to work great, except when I select “Where to?” from the main screen and then “Address” in order to manually enter an address. The first prompt requests “In What State/Province is the Address?” Previously, I believed that the first prompt was for the street number.

Anyway, no matter what state I type in, the response is “No Matches Found.” Thus, I’m prohibited from manually entering addresses.

Under “Settings/Map/Map Info”, the correct OSM World Routable Map is displayed and checked.

Any ideas???

I have the same issue with the Queensland, Australia map on a Garmin Oregon 450.

The map displays correctly and in simulation mode (I’m still in New Zealand) I can get it to auto-route to Cities, Points of Interest and Waypoints.

However if I use Where To? > Addresses > the only option is to tap the “Spell State/Province” icon and spell something. Various combination’s don’t work (likeA,Q, Qld, B (for Brisbane), leaving it blank etc.

On the earlier hand helds and we can skip that State/Province bit.

Thanks for any assitance - Tony

The address search index of the Garmin map format is not fully understood yet. So the implementation in Mkgmap (the application that generates the maps) is only partial. The problems that you describe are the result of this.

I’ve stickied this thread as it is a frequent question and an issue with all OSM Garmin map providers.

OK, thanks for the update. The New Zealand Open Project mappers had this issue too with the nuvi models. They had to change the way it was processed and the problem was solved - NZ maps form

I don’t know the details of the change but a nuvi (etc) can now global search (all of NZ) with the one proviso that a City name is not used. Also, on the 1xxx and later models the street name has to be in all upper case. A keyboard modification is posted on the forum to force it to stay upper case instead of reverting back to lower case after the first letter.

Don’t they use cGPSMapper for creating their maps? cGPSMapper is closed source (and non-free for advanced options). I’m using the open source Mkgmap application for that…

Some previous discussions of this problem:

I have the same problem on my Nuvi 250 and tried the NZ maps, they work so these NZ boys seems to have solved the problem, but i can’t find how they solved it.

I have the same problem with a nüvi 350 and the maps from:

I use the germany and europe maps and there is also the “State/Province” Problem.

Every map created with Mkgmap will have this problem which means that almost every map from this list has the same address search behavior.

Address search will mostly work via one of the two methods provided below:

  1. If your GPS asks for a State/Country code then don’t use the address search but use the following two-step process:
  • Search for the city/place name. Select it.
  • Search for the street name. Select it.

This works for: Nüvi, …

  1. Otherwise you can use the normal address search, but:
  • Enter any housenumber first (it does not have to be an existing housenumber)
  • Enter the streetname (at which point the GPS will start providing feedback about possible matches). You can choose the street from the matches or
  • Enter the placename to narrow the search down to the correct street.

This works for: GPSMap, Etrex, …

It would be nice if people report back which method works for which device then I’ll keep this post up-to-date (just the group name if it’s not already listed, there’s no need to show all the variants within a product group).

Hello Lamertus,
I will test it tonight on my nüvi 350.
But why can’t we use the same programm as the guys from “New Zealand Open Project”? I think it would help alot of people if the maps would be greated with an adress index, even if it is created just once every six month.
Or could I create the maps with the address index on my pc? Do you know a way for that?
I will report back tonight.

Because they probably use cGpsMapper which is a commercial application. I like the opensource nature of OpenStreetMap and Mkgmap and have no intention to buy a cGpsMapper license. Ever.

Sure, it would be awsome. But it isn’t right now. However, I did expect the devs to find the solution earlier though (this is not a complaint, apparently it’s just harder to figure out then I thought).

I have no idea.

Hello Lambertus,

On my nuvi 250, SW 5.0 i can search for a city, but after that not for a streetname. For selecting the city entering a zipcode isn’t possible, what can give problems when there a more cities having the same name (common in the netherlands). Without selecting a street you have to select a street using “address search” when you are nearby the destination. That takes a long time on my nuvi. Also operating the nuvi when driving isn’t safe.

I now use the following procedure

  • select the standard garmin map (city navigator)
  • select the destination using the standard procedure
  • unselect the standard garmin map (city navigator)
  • select the (new) updated map
  • select the destination using the “recent found list”

selecting the destination using favorites is also possible without changing any map selection

I tried to make a map (.img) using cGPSmapper (personal and free version) but both versions have the Enter State/Province problem.

Ok thanks, this address thing is always more difficult then I think apparently.

Just found another complication. Apparently the search range doesn’t really go beyond the tile you’re positioned in. This is becoming a problem too with all those small tiles popping up everywhere.

I tested it with a the “All in one Garmin Map” from german on my Nüvi 350 EURO
I can not use the address search, because of the state problem.
I can search for cities. (Typing is really slow, much slower than with the build in maps).
After that I select the city and navigate to the city. Then I do a Search near … “My destination” und use the “Spell Name” slection.
Here I can NOT search for streets. It will not find streets, it seems like only POI’s are returned.
Search on “Intersections” also does not work because of the State problem.

I have found no way to search for a street in a city with the OSM maps.
The only workaround would be to select the build in maps and search for the street. Then activate again the OSM Map goto “My Locations”, choose “Recent Selections” and choose the street.
But this is a huge workaround which might work for us technical guys, but sadly not for my mother.

So for any solutions with the address index I would be really thankful.

Thank you very much

P.S. If you or the Mkgmap guys make the search for addresses possible this would be a huge push for OSM! Because then you just need simple cheap hardware from garmin and you have workwide routable maps available.

If you’re desperate for street search, you can compile your own map with mkgmap using the --road-name-pois option (–road-name-pois). This creates a POI for every road, and you then search for the appropriately named POI. It’s an ugly kludge, but some people use it.

The big kludge about it, is that it breaks POI search. Meaning you will not find many POI (especially distant) anymore, even though you should, because the database gets overloaded.
Essentially this kludge is crap!
(worse, if a user uses several maps, it’s enough if one is built with --road-name-pois to break POI search for the whole unit…).

I have had that option enabled once and got a lot of comments complaining about poi symbols showing up on every road. It’s only usable for specific devices. I agree with the comments above and I’m not going to use it for my maps.

I’ve got a Nüvi 205w I don’t see the state option, but I can see the city/housenumber/street option. In most of the cases I can’t even find the city, in some I can find city and street using a bogus housenumber. Just in a few cases it routes to destination, but in most ends with a message “No results found” even when you’ve been able to correctly enter your destination.
Some strange behaviors like name duplication for cities like “CityName” and “CityName ABC”

On my nuvi 205 the address search for cities and streets is limited to the currently selected country.
And since the OSM data from has no country code (as described above) it can not be selected as a destination for routing.
Is there a solution around that?

One idea as a suggestion:
Would the nuvi be searching the OSM data if everything would have the country code “world”. This would make the search maybe slow, but at least the OSM data could be accessed.

Are you sure that providing a country code would allow address searching on the Nuvi? I hadn’t heard of that before…

Hi Lambertus,

I am not sure that adding a county code would help. I just put one and one together.
You mentioned the fact that the OSM data from does not contain a country code, because there are several tiles for one country and several countries for one tile.

On my Nuvi I loaded the OSM data successfully. Thanks a lot for this wonderful service! On the Nuvi the destination addresses are limited to the currently selected country.
The OSM data on my Nuvi contains the map of Kenya, but Kenya is not available in the country list and so it is not possible to select an address in Kenya as a destination.

How does Garmin add new countries to the list of countries? I guessed it would work via the country code, but it is only a guess.