Problems Entering "State/Province" Name on Garmin nuvi 200

If you are using a TYP file, you can use invisible road name pois. :slight_smile:

Hey Lambertus,

I just bought a brand-new nuvi 1490t with a SD card and copied your map on it. The search problem seems to be even worse on this device. If you go to Where To? → Address, an error message shows up saying ‘No Map Data Available’, not allowing you to search for anything whatsoever. Initially I was worried it was a problem with my device, but I tested it with the default Garmin maps, with which it works just fine.

I tried the workaround you mentioned by searching for the City first, then the Address. On this device, when you select Where To, a new screen pops up allowing you to select a variety of options, such as Address, POIs, Intersections, Cities, etc. The Cities (and POI) option works just fine, allowing you to select the city from a list of closest ones or type it in. The problem is that if you choose to do so, it only points you to the city and won’t prompt you for an address. If you try to leave the option and then select Address, the same error message aforementioned pops up, thus rendering the workaround ineffective. I noticed too that the same ‘No Map Data Avaliable’ message shows up when you press the Intersection option. But, if you browse the map, all the street names show up neatly. I’m just explaining it that thoroughly 'coz I don’t know if older Garmins work the same way as mine does, and maybe this difference may give you a hint on how the Garmin folks encode their addresses. I personally am just a mere human which barely knows how to type in an internet address. XD

I gave it a bit more thought these days and maybe the following is relevant:

  1. I’m in Brazil, but the device is from Europe, so I have the ‘official’ Garmin maps for EU and the OSM maps for Brazil, thus the area of the globe of these two maps don’t overlap. I didn’t download the EU OSM maps since I don’t want to clog the server with such an unnecessary download for me. I think this isn’t relevant, but hey, maybe you guys can figure something out.
  2. I am currently actively editing the Brazilian maps on OSM and I noticed none (or very few) of the streets contain house number information, ZIP Code, or even city (I noticed you can add a tag for every street mentioning to which city/state/country it belongs to) hence, this information is missing, or using Garmin terminology, ‘not available’. This mustn’t be too hard to fix, since you may simply select all street of the city and add the tag simultaneously for all of them. I just didn’t do it because it would be such a massive change with doubtful results that I might upset a person or two with it. XD

Summarizing what I wrote above: For Garmin Nuvi 1490T, the Where To? → Address option doesn’t work, triggering a ‘No Map Data Available’ message instead.

Ask me anything you want to know more about this device, or about anything else, and I’ll happily reply.

Thanks to all of you,


On my Zumo 660 using 2 Thailand tiles only, I can see no city names (in search, that is), but I have the option to search all. With this it finds street names, but when I select one it just says “No match”.

have no intention to buy a cGpsMapper license. Ever.

That sounds so hostile?.. I don’t know whether you intended that. We should remember that Stan, the author of cGPSMapper single-handedly (as far as I know) decoded the Garmin map format and it’s because of him that we have any 3rd party maps at all. Try to find any for any other brand of GPS.

In any case, soon you don’t need to buy any licence any more: cGPSmapper is being released as OS now:

No, I did not intend to come across as hostile towards cgpsmapper. I just stated that as a fact.

He is apparently a very smart guy and/or very patient and if he want’s to make money with his software that’s fine with me.

But the point is: I’m working hard to promote and improve free geographic information and to provide that information as free maps. I don’t get paid for that, I don’t want to get paid for that. And so I want to use only free software to accomplish that: Linux, NSIS, Mkgmap, Java, translit, PHP, JavaScript, OpenLayers. The whole ecosystem. So, if there is a free (and almost as good) alternative for cgpsmapper then why should I want to buy a license?

That is great and a brave decision of the author of cgpsmapper.

So to sum up: I have no grudge against anyone wanting to earn money with something. Everyone makes their own choices and equally I have made my choices.

Currently only cpreview is available as OS. Code is difficult to read due to loads of Polish annotations however. And it’s not because of cgpsmapper that mkgmap or 3rd party maps exist, but due to work that happened OS before cgpsmapper.

On top address search and inter-tile routing in Mapsource/Basecamp are the only advantages that cgpsmapper still has over mkgmap. Two years ago that was different. By now in general for OSM map data mkgmap is far superior as cgpsmapper is not adapted to osm data. Currently there is a lot of work by mgkmap devs to get address search working. But as cpreview code is not fully understood, and cgpsmapper not (yet) OS it might still take some time till it will work (and then the problem is, that very few addresses are inside OSM for now).

Thanks for the clarification, guys. Lambertus, I understand what you mean and as I said, I didn’t think you intended to sound hostile. But such is the net: easily misunderstood.

Have a nice day.

Recently there has been some progress in the mkgmap development and the index based search is already working for small maps.

Edit: Now it’s working also for large maps.


Yep, good news indeed. I can’t wait until the Mkgmap index branch is merged with trunk.

I have tried to use the osm data for several uses.

(I also use a cgpsmapper commercial version as well as mkgmap) The main problem is that streets have no city index.

For example: Witmoesdijk this road is not assigned to a city .
With searching there need to be a city index. To that city belonging all roads in the city. Then it is possible to search for enter, witmoesdijk, 16 .

There for you need to set all roads to a city.

Guido, the latest locator branch in mkgmap almost suits your needs. The guys from mkgmap are working on it, the results look promising.


Witmoesdijk can now be found on my latest Openfietsmap, it shows two locations, Enter and Rijssen. I’m not familiar with that area, but it looks like it’s working very well in my area (Amersfoort).
I’ve compiled my map with the locator branch (mkgmap-locator-r1896.jar).

I have just generated a larger map of germany and surrounding country-parts using the standard mkgmap-r1908 (details are posted here:, upload to SD-card requires MapSource, MapSetToolkit, and MapInstall to generate the appropriate adress index). A search for “Witmoesdijk” gives “Witmoesdijk, Enter, NLD” as first result on my eTrex Vista.

It is important to follow the guidelines in the beginning of this post. With the eTrex, I have to make sure that no “region” is entered (otherwise the garmin has to be switched off and on). Then 1 has to be typed in as housenumber, followed by the street.

Dear Lambertus,
Many thanks for the wonderful work you do for our benefit. I really appreciate and admire all contributors to this project around the globe.
I’m relatively new to all of this but have succeeded in downloading the New Zealand maps and updating the keyboard. I now use my Garmin 1490 on a daily basis there. My problem relates to US maps:

I am visiting family in the US and downloaded the Minnesota tiles from OpenStreetMap into Mapsource and then sent it to my Garmin device. On Mapsource, I am able to see the names of all streets on the map.
On the Garmin, I see the map but it seems to have loaded only the detail about the highways and points of interest. When I press “Address” it says that there is no data. I am therefore unable to enter in any addresses. I have saved some favourites by selecting “Where am I?” but when I try to navigate back to these places, it does not know any street names other than the highways and it tries to take me from one highway to another with no regard for other streets.
Today I downloaded the file: 500MB-lon_-99.23_to_-92.37.gmapsupp.img 09-May-2011 13:45 466M. I have been unable to unzip it as it gives an error: “ERROR: Internal error processing ISO image”.
I hope this is clear. I am only in the US for a short period. Do you have any suggestions to allow me to get the maps for the Twin Cities working on the Garmin while I am here?
Kind regards - Paul Auckland

Hi Paul,

For NZ I suggest you use the NZ Open GPS Map instead.

The file you downloaded is not an ISO image, nor is it a zip archive. You need to rename it to gmapsupp.img, connect your GPS to your computer, find the Garmin folder and rename the existing gmapsupp.img (to save whatever maps you already have), then move the new file into the same Garmin folder.

Sounds like your GPS is only using the basemap for routing.

Sounds like you’re not using my maps but someone else’s.

Have you tried to download from selecting only the tiles you need and entering your email address? The queues are very short lately so you should get your custom map quickly.

Many thanks for your prompt response Lambertus,

All sorted now. I still can’t enter addresses into the Garmin 1490 for the US but am able to do everything else, so very satisfied.

What you guys are doing on this project is absolutely amazing.

Thanks again


Thanks also Beddhist,
That was very useful.
Kind regards

For the benefit of other users: may I ask what you’ve done to fix your problems?

Hello Again,

From, I clicked on the link: North America and scrolled down to the link: OSM dev server user daveh under the column heading, United States.

I downloaded the map with the longitudinal co-ords relating to the region I required and copied this onto a 4GB memory card. I renamed my New Zealand maps to NZgmapsupp.img and then renamed the new maps gmapsupp.img.

This worked except it does not allow me to enter in addresses. It is still invaluable though. Each time I have arrived at a location that I wish to return to, I go to tools/where am I? on my Garmin 1490 and then store the location as a favourite. That way I am able to return to that address from anywhere. Being new in the city, I’m especially pleased to have the confidence that I can always find my way home.

Thanks again for your help.

Best regards

my underdstanding is that you must use the mkgmap locator branch to then generate a map file to import in Mapsource, then create the gmapsupp.img file from within Mapsource and upload it in the device- this would then allow the actual address search in the garmin device. A img file created directly from mkgmap is (still) not allowing a proper address search.

Any osm/mkgmap-guru can confirm this understanding is correct? Thanks!