I'm getting a Osmosis error: No default pipes are available

I am running Windows and using the osmosis.bat file that came in the osmosis-0.48.3 file.

I’m trying to reduce the size of the osm.pbf file based on the information at OpenStreetMap map size reduction guide

The first two steps worked fine. The third step generates the following error:
SEVERE: Execution aborted.
org.openstreetmap.osmosis.core.OsmosisRuntimeException: No default pipes are available as input for task 12-merge.

Here is the command I am running within a batch file: os-3.bat

osmosis --read-pbf file="canada-latest.osm.pbf" --tf accept-nodes place=country,state,region,province,district,county,municipality,city,town,village,hamlet,isolated_dwelling,farm,allotments" --tf reject-ways --tf reject-relations --sort --read-pbf file="canada-latest.osm.pbf" --tf accept-ways place=country,state,region,province,district,county,municipality,city,town,village,hamlet,isolated_dwelling,farm,allotments" --tf reject-relations --used-node --sort --read-pbf file="canada-latest.osm.pbf" --tf accept-relations "place=country,state,region,province,district,county,municipality,city,town,village,hamlet,isolated_dwelling,farm,allotments" --used-way --used-node --sort --merge --merge --write-pbf granularity=10000 ".\output\canada-latest-place.osm.pbf"

I’ve done some searching and the only thing I came across here in the community. I see references in their post for outPipe but don’t know how I would implement that in my batch file.


osmosis -v 5 --rx zuerich.osm.bz2 --tee 2 outPipe.0=all1 outPipe.1=all2 --tf inPipe.0=all1 reject-relations --tf accept-ways amenity=car_sharing --used-node outPipe.0=ways --tf inPipe.0=all2 reject-relations --tf reject-ways --tf accept-nodes amenity=car_sharing outPipe.0=nodes --merge inPipe.0=ways inPipe.1=nodes --wx result.osm

This doesn’t directly answer your question (there is sure to be a small error in the arguments).

For command line usage osmosis has essentially been replaced by osmium Osmium Tool - osmcode I’ve never used it on windows but there is a build available (otherwise it is sure to run in WSL) and I would suggest that for any new work to use it (particularly in this case because you can save filter specs in a file).

1 Like

I came across the tool osmium earlier and downloaded it. I’m not a programmer. The problem I ran into with osmium is that it is only the source code and requires a compiler which I don’t have. I’m sure there might even be one I could download for free but I really don’t want to have to do that if I can avoid it.

There are pre-compiled windows builds available, see the bottom of the page I linked to.

To be fair it’s not entirely obvious that Conda-forge will take you to a Windows build, but it will.

1 Like

Unless I’m completely missing something. If you are referring to where it says; Installers, those are just code to look like links and not links.
Osmium Tool __ Anaconda.org - anaconda.org

Those appear to be code to look like images / links and not actual links. Perhaps I’m just showing my age of 66 and not finding it If there is a link to a build of a Windows executable that I’m just not seeing please provide the direct link to it.

The line to install; “conda install -c conda-forge osmium-tool” returns;

‘conda’ is not recognized as an internal or external command, operable program or batch file.

1 Like

If you click on “Files” there are links


But I am not sure if you can use these directly or have to install anaconda before.

1 Like

Yes you need to install Miniconda first I think which will then give you the conda command though I agree it’s all as clear as mud - it took me ages to figure out where to get the installer for conda!

1 Like

I’m sorry I should have specified in my previous post that I downloaded the file osmium-tool-1.15.0-h8558f88_0.conda from the files section. It was when I ran the command they show to install it I got the error.

I think osmium has to already be installed. I’m sorry, not being a programmer I sometimes require step by step instructions to accomplish things.

In my situation my task / goal is for myself to build maps for my use not to mass produce something for hundreds or thousands of others to use. I’m currently getting the garmin maps I am using for Canada and the U.S. from OpenMapChest. He had posted in 2021 that he was shutting down his site in early 2022 but didn’t. I’m just trying to prepare for in case he does by being able to make my own maps. If someone else can benefit from them as well I have no problem providing them but my goal isn’t to replace openmapchest.org

if all you want is get Garmin maps based on OSM, you can try your luck here:

Regardless of having the same source data (OSM), these maps can be very different, according to the intended usecase (e.g. you need a completely different map for hiking in remote areas compared to driving in a car)

For your install problems, it is not osmium that has to be installed, but conda. Install the miniconda from Toms post and then the command line install of osmium should work

1 Like

Thanks Tom. I’m downloading Miniconda now.and installing it. We will see how things progress from here.

The link you provided is where I found OpenMapChest. It has been the best option for my needs since I ride a cruiser style motorcycle. I had no problem giving a donation for the need it filled and service provided.

What I have been doing is downloading the .osm.pbf and poly files for Canada, U.S. and Ontario (the province I live in) from Geofabrik for North America Since the files are too large for my Garmin unit(s) I have been working on trying to replicate as best I can the maps from OpenMapChest.

On my first attempt I got them to work but unpaved roads weren’t showing as dotted lines. My big heavy cruiser doesn’t do the greatest on unpaved roads. SomeoneElse / Andy provided the solution by pointing me to the OpenMapChest map build guide which solved the issue. Now I’m trying to reduce the size.

You were correct Simon, it turned out to be a small error in the arguments. I thought I checked the file carefully enough to make sure I had the arguments correct. I missed the " marks in two spots.

I could have saved not only time and grief but avoided wasting people’s time replying to a post that I wouldn’t have made.


And particularly:

Alternatively, I also have a build with the exe and required dlls all together, here… GitHub - pango3001/Osmium_1_14. Then you can just add osmium as an environment variable in Windows and point it to whatever directory the exe is in.

I just downloaded it.