Zooming with the mouse wheel skips zoom levels

Zooming with the mouse wheel does not seem to work properly for me. For example when I’m at zoom level 300m and scroll one “click” back I end up at 3-5km (this varies) while I expect it to be at 500m, just as if I pressed the “-” button on the top right. The same happens when scrolling forth. I’m not having any issues with my mouse wheel elsewhere, it also works perfectly fine on Google Maps.

Tested browsers: Chrome 88.0.4324.190, Edge 88.0.705.81, Firefox 78.8.0esr
Operating system: Windows 10 Home
Mouse: Logitech MX Anywhere 2S

Does anybody have a clue? Thanks in advance.

Have a look at your mouse settings (windows key + type “mouse settings”).
The default for “Choose how many lines to scroll each time” is at 5.
Values higher than that might influence your zoom level steps.

Hope this helps.

This setting was configured to 3, but even if I set it to 1 the scrolling behavior on OSM is the same.

Finally I found the culprit, it was the setting “smooth scrolling” in the Logitech Options software. After disabling that everything works again as expected.

Thank you, you are the best! This fixed it for me.