Worldwide routable Garmin maps: URL REMOVED

Don’t see anything wrong there, footpaths and tracks should be visible

Huh, it took me 15 minutes to figure it out. Stupid!!! My basecamp was set to activity “driving”, thus no footpaths. Because of your help I figured it out and set the activity to standard “walking”. The footpaths are there.

I thought I could use these wonderful maps to update my old Garmin GPSmap 76C, but on the device I see only a few crude parts, most freeways and very few other roads. The rest of the map, like cities, is empty.

I used BaseCamp to upload. In BaseCamp the maps show completely and look good.

Any idea how to work around this defect? I have already tried whatever I could, to no avail.

The latest version of BC is reported to have a serious bug, causing such problems. You have 3 choices:

1 - downgrade to the previous version and turn auto-updates off.
2 - Use MapSource, also free from Garmin.
3 - download the img file and copy it directly to your GPS.

Good luck!

Thanks a lot! I uninstalled BaseCamp 4.7.0 twice, because it was there twice, checked that the folder MapInstall had also gone (otherwise I would simply have deleted it), and installed BaseCamp 4.6.2.

This solved the problem entirely. I could immediately upload all the OpenStreetMaps to the Garmin GPSmap 76C without any problems, and the maps appeared on the device in their full glory.

There is a problem showing Tortolì.

I have created a a Generic Routable (new style) map of Sardegna, downloaded the macosx maps and use it with Mapsource and Basecamp. The city Tortolì is shown as Tortol? in both Mapsource and latest Basecamp.

The maps are not using (all) unicode characters because some Garmin devices don’t support that. It is possible to create such a map with mkgmap but I don’t know any provider who compiles maps with that codepage.
Or do you think that the name is Tortoli (with a normal i)?

@Gerd supports UTF-8 unicode, dont know if that helps?

Noticed that on my Openfietsmap Tortolì is rendered fine (I use latin-1, code-page: 1252 characterset to compile my maps).
Any idea what could be the cause Gerd? As far as I know Lambertus also use this codepage.

Maybe he doesn’t use those option for the generic new style maps?

As far as I know he did use this but maybe his settings are messed up lately. I can’t contact him though, he never responds so better use another map provider.

I’ve just downloaded the map tile and analysed it with display tool. It contains two different spellings: TORTOL? and TORTOLÌ
I see two possible reasons: Either the used bounds file contains a wrong spelling or the actual OSM data contains it.

Last edit is 3 years ago, so an issue in the actual data does not seem likely. I dont know what the bounds file has to do with the rendering of the place node?

How do you know that this is about a place node?

Well, you are probably right, the node with label TORTOL? is shown at

Maybe it is caused by the transliteration that Lambertus does while processing his maps:

Sure, if that is still active it could be the reason.

I’ve ssen this thread before posting my question, but I thought it’s 10 years old, so it should be fixed. Well, who knows.

City Navigator shows the correct name: Tortolì

At least 300 seconds have to pass between posts. Please wait 231 seconds and try posting again.

REALLY? :roll_eyes:

Well, Lambertus the maintainer of the maps seems not very active anymore with development of the maps nor watching this forum so don’t expect too much. We should be glad he still is updating them anyway.