Worldwide routable Garmin maps: URL REMOVED

It looks like the update this morning came at an inconvenient moment. The server disk was already quite occupied due to the website changes earlier this week so there was already little room for the typical surge that happens after each update, but now every request is just locked in the queue waiting for some disk space to come available… Currently there are 71 requests queued.

Price of success? :sunglasses:

Edit: (2.5 hours later) 100 requests in the queue.

The former list of choosen tiles was better for people who did their download manually. E. g. I choosed 10 tiles, then I copied the name of the tiles per copy and paste to a textfile and downloaded the tiles with a bashscript to build my gmapsupp.img manually and with my typefile.

With the new names (townname instead of tilenumber) this is not possible any more, because the name of the tile and the name in the downloadlink is different. Now I have to request for a gmapsupp.img or I have to download each single tile manually before I can build my own gmapsupp.img.


EDIT: Ok, I found a solution to download the choosen tiles without a request to your server for a gmapsupp.img. I copied the names of the tiles and together with the world.kml of your homepage I have the names of the tiles to download directly. A bashscript will download the needed tiles via wget, no more requests to your server neccessary.

EDIT2: The implementation of the streetnames as POIS is working as expected, great! Now all Oregon users can search for addresses via ‘All POIS’ or ‘Geografic points’ (preferred), thank you very much!!!

Great, that is what I thought of too, but I didn’t dare to suggest it :wink:

You’re welcome! :slight_smile:

Edit: Blegh, the back-off changes were implemented a bit too early in the script. It didn’t cause the script to backoff when it was already running (an processing 100 requests). So the result, again, is that some requests failed. I’ve now moved the free-disk-space check to be within the request processing loop. I hope this was the last time requests failed because of that reason. Again, I’m sorry for any inconvenience.

Lambertus, could you please give us the source (cloudemade or geofabrik), the commandline options of mkgmap and the used version of mkgmap you are using to build your routable maps?

It would be helpful for users who want to build their own maps or who want to compare their own maps with yours.

Thank you,


Download the planet file if you plan to render the entire world, like I do. Otherwise download from a Geofabrik or Cloudemade extract or from any other extract source.

The next two steps are performed recursively until Mkgmap was able to render the source data successfully.

  1. Split the planet into tiles that can be processed by Mkgmap:
java -Xmx3400m -ea -jar ~/garmin/utils/splitter/splitter.jar --no-trim --max-areas=150 --cache=cache --mapid=$mapid --max-nodes=$max_nodes --write-kml=$name.kml --geonames-file=../../ planet-latest.translit.osm.gz
  1. Render step (done before each release):
ulimit -t 600 && java -Xmx1792M -ea -jar ~/garmin/utils/mkgmap/mkgmap.jar --road-name-pois --adjust-turn-headings --latin1 --name-tag-list=name:en,int_name,name:zh_py,name:engels,name --remove-short-arcs --add-pois-to-areas --make-opposite-cycleways --link-pois-to-ways --route --description='OSM World Routable' --series-name='OSM World Routable' $file

Combining step (done on request of the user):

Java -Xmx2048M -jar $utils_dir/mkgmap/mkgmap.jar --index --overview-mapname=63240000 --series-name='OSM World Routable' --latin1 --description='OSM World Routable' --product-id=3 --family-id=2000 --tdbfile --nsis --gmapsupp *324*.img

The Mkgmap and Splitter tools versions are mostly the latest available. There is another too, which isn’t opensource (yet, I certainly hope) that transliterates non-English names to English. Anyone doing some serious map building outside the ASCII or Latin1 language areas should experiment to make their Mkgmap parameters suit that situation. I don’t have any experience with that, so I can’t help unfortunately.

Thank you,


It looks as if it is grabbing the corners of the state selected and not quite firguring out the rest between them.
Does the same for Colorado, Wyoming and others, though CO & WY are square so there’s only four corners to see.

Lambertus, Any idea what the current queue time is. Replies seem to run over 12 hours? Or has something gone wrong with my e-mail address? Hugo

There are about 180 requests in the queue at this moment, yesterday evening 130. I’ve cleared some old files so I hope the queue is shortening a bit.

Edit 1: But looking at the CPU usage graph, having much more spare disk space wouldn’t have helped much. The CPU is pretty much running flat out most of the time anyway. I guess, it’s just more busy then usual after an update.

Edit 2: The download stats confirm the busyness: twice the usual bandwidth usage the last two days.

Edit 3: The cleanup script allowed 72 hours downloading before deleting, it has been reduced to 48 which resulted in a lot free disk space. I think the queue of 200 request will reduce now.

Yes but matchit cannot do much about it. It is designed to work with country polygons that describe a closed loop boundary. Then it is 100 percent correct. But instead it is offered polygons (from cloudmate mostly) wich are mostly many rectangles within the country boundary. Mostly this will go ok but sometimes like for italy some small tiles miss. So for italy a plolygon from geofabrik is taken. I’m pretty sure that the new york scattering has the same reason. All can be sorted out by supplying good country poligons.

Sorting countries on alphabet is done by machit now also.

First, let me thank you very much for this great service. Living in a developing-world country, it is absolutely great to be able to get routable maps. It has also been a rewarding task seeing the areas I mapped be added.

But, I have a problem. I asked for the tiles for Bolivia and received the response below yesterday. Unfortunately, only files there are:

Parent Directory	 	 -
mkgmap.version	09-Feb-2010 00:01	 4	09-Feb-2010 00:01	 34M
requested.tiles	09-Feb-2010 00:01	 26
requested.time	09-Feb-2010 00:01	 20

There is no gmapsupp.imp nor MapSource installer. Is this something I did wrong?

Thanks for your help. The response letter is below.


Your request for a routable Garmin map on is ready.

The server has generated four different configurations of your map:

  • Installer for Garmin MapSource (Windows).
  • Installer for Garmin RoadTrip (Mac OSX)
  • Combined image for direct manual placement on the GPS device (gmapsupp.img)
  • A zip file containing the tiles in the request, especially useful for Linux users (e.g. QLandkarte)

Please browse to the website listed below and download the map configuration(s) you’re interested in. Your request will be available on the server for 48 hours before it’s deleted.


Hi Lambertus,

Has anything been changed with the system that generates RoadTrip maps? I downloaded a map and MapInstall gives an error: “Alert. There is a problem with the OSM World Routable installation. Please re-install OSM World Routable and start MapInstall again”

I tried re-installing the map to no avail. I reinstalled the previous OSM routable map and it works fine with MapInstall.

Interestingly the problem map is installed to RaodTrip with MapManager no problem. Its just MapInstall finds an error with the map.


You didn’t do anything wrong, something did on the server (don’t know why this time). I’ll remove the current combine result and try to make a new one with tiles 3 and 4 (the ones you selected). Hopefully this was just a hickup…

The server is still 2 days behind with around 100 requests in the queue and disk space rapidly nearing 0 again which means the last two days required about 100 GB of storage.

I hadn’t heard of this problem before. A newer version of Mkgmap has been used to render the tiles, that’s the only possibly relevant change since the previous update. I’ll see if a source can be found…

Hi, I been having problems with the maps from Australia, Along the East Coast for the past week. Attempted to download 3 or 4 times the maps and still have the same problem. The tiles on the Furthest East of the Coast are not working in Road Trip on my Mac. The colors on those tiles are not the same as the others and I can’t zoom in very far. if I try to zoom in The maps disappear.

If I zoom in any closer than what’s showed in this photo the roads etc disappear.


I am having the same problem as philipstart but with Mapsource. The problem only seems to be effecting the tile that covers the extreme east of the Australian continent north and south of Brisbane. When I attempted to use this part of the map Mapsource generated an error mesage that requested detail be sent to Garmin but as the problem seems to be occurring in other applications it seems that the problem may be with the download as the OEM map in both View and Edit looks fine. Please advise if you need any more information.

Khank you.


Just to add some more info. The ‘previous’ OSM routable map, that works fine for me was based on OSM data from 20-01-2010 and I downloaded it on 30 Jan 2010. Requested tiles were 63240454.img, 63240455.img, 63240456.img.

The ‘problem’ OSM map is based on OSM data from 3 Feb 2010. I downloaded it 10 Feb 2010. The tiles are requested were 63240409.img, 63240410.img, 63240412.img (Ireland). I chose from the new preselected drop-down menu)

I have the “.nsi” info from both downloads if that’s any use. The mkgmap version file simply says “svn” for both maps.

This may be a problem specific to the map you have downloaded. Perhaps you could let us know which tiles you downloaded, or the directory of your download, so we can try to reproduce the problem. I was able to successfully install other tiles, so I don’t think it’s a general problem.

You may also wish to try the latest MapInstall beta. This version appears to be much more stable than previous releases:


I tried again with these tiles ( and was able to install without any errors – I did use the beta version of MapInstall though.


I still having the same problems as I posted a couple days ago.

The tile on the far eastern side of Australia is not working. I can’t zoom in any closer than 5Km as shown in the image I posted a couple days ago.

I am not using Mapsource. I am using Roadtrip on a Mac. It’s been like this for a week and a half now. Unfortunately the area in question is where I live and travel.

The directory was but I think its dead now, sorry.

I am using MapInstall Version 2.1.3 Release. This seems to be later than the beta in your post. Do you reckon its better to downgrade to the older beta ?

Just to clarify, I am able to install the map onto RoadTrip fine. Its just transferring the map to my GPS unit via MapInstall brings up the problem. I tried clicking on the link you posted for the tiles that worked for you but the link is dead.

I’ll try to download a new set of tiles and I’ll let you know what happens.

Oh yeah, I just want to say a very big thank you to Lambertus and yourself (and all who contribute) for this EXCELLENT service. It is superb. OSM and my Garmin GPS unit would be nothing with out the ability to use the OSM maps on my GPS unit. I have used your service for just about a year now and it is excellent. I appreciate your good work. Cheers.