Why some parts of maps doesn't load?

I’m new at openstreetmap. I created a map with weather radar. It works good until today. As you see there are some of parts map is lost. Is it temporary sitituon or repeat regulary and how can I get rid of this. http://cihanyeter.com/resim/openstreetmaphata.jpg

Hi and welcome to OSM and the forum

There can be multiple reasons why tiles are not loading. Try to clear your browser’s cache and do a forced reload (usually Shift+F5). You can also check your browser’s web-console (Crtl+Shift+K in Firefox) if there are any error-messages.

Thank you but I don’t think the problem is not on my side. Could you check it https://www.openstreetmap.org/#map=8/34.244/-89.594

Works for me. No broken tiles on any zoomlevel. There have been some issues with tile-rendering a few months ago. Since I never had any problems I wasn’t following the discussion. My IP-Provider is in the UK, so this might be a reason. Check your web-browser’s console to see if you get any errors.

Yes you right when I use VPN it worked perfecly. I get this error : http://cihanyeter.com/resim/openstreetmaphata2.jpg
Is there anything that I can do? I use the map in my app which is using in other counries, how can I know who gets this error or not.

As https://operations.osmfoundation.org/policies/tiles/ says “OpenStreetMap data is free for everyone to use. Our tile servers are not.”

If you create your own map tiles you won’t have this problem. Alternatively, use another tile provider, perhaps one of https://wiki.openstreetmap.org/wiki/List_of_OSM-based_services.

Ok. Thank you

Which version of Chrome are you using? It sounds like a issue that was fixed in chrome recently, see https://chromium-review.googlesource.com/c/chromium/src/+/2001234

If your app doesn’t report errors back to you, you will never know since this is a communication problem between the app and tile.openstreetmap.org . What I found as a first glance over the results in Google searching for “err_http2_protocol_error” was that it seems to be a communication problem between server and browser. Maybe when using VPN some http-headers get modified so the problem doesn’t occur when using VPN.

@Spiekerooger I got same error with firefox and opera too.