Why Red Rash on Map?

I downloaded a map section using bbike.org for my ETrex 10. The map loaded into QLandKarte has red hash over much of the area. What does the red mean and how can I get rid of it?

2 Likes

I assume it’s denoting the landuse type.

2 Likes

Hi, If it’s the whole map there might be something wrong with your app or the download. Is it the whole map or just an area? If you can give a link to the position of the rash someone might be able to tell you the reason for it.

I think you are running QMapShack, not QLandKarte and that you have downloaded a Garmin .img file, placed that file in one of the QMapShack map paths and did activate it.

I did something similar, got a .img file from OpenFietsMap and I see:

Screenshot_20230507_095558

I can also get such red hash by pressing the right mouse button on the map and selecting Add Area:

Screenshot_20230507_101608

Next you can drawn an area and while doing that I get the red hash, but after finishing it is is a blue hash with a given name (Area in this case):

Screenshot_20230507_102106

So this must be something QMapShack specific.

2 Likes

Rendering of Garmin maps is controlled by a TYP file, generally embedded in the IMG file. QMapShack allows to override the embedded TYP file by a custom TYP file. I suspect that either your IMG file does not have an embedded TYP file or you did override it by inadvertance.

emvee, you are correct, I have updated to QMapShack. Teses are coordinates for part of my small map
N41.737077° W88.165763° It is only about 20 miles square because of memory limitations in the Garmin Etrex 10. Here is a screen from the older version of the map (which I am trying to update). It does not have the disease.

If land use is correct, how can I turn it off?

This is my display of the Rotterdam clip.

I think I fixed it. Changed ~/.config/Qlandkarte/QmapShack.conf:
Views\View%201\map\813a548cd2bfe8e1b55f0981c9681175\showPolygons=true
to:
Views\View%201\map\813a548cd2bfe8e1b55f0981c9681175\showPolygons=false

The rad rash is gone (along with some other useful information)

1 Like

Good you found the problem by setting “showPolygons=false”.

I think it should be possible to do that also in QmapShack whithout disabling showing Polygons just by deleting these polygons.

If the Garmin disk image was XML I might be able to do that. Turning off all polygons is not a good solution. I think the problem is GIS data coming over from OpenStreetMap. I need a way to disable that.

– The only difference between men and boys, is the price of their toys.
http://wb8nbs.wordpress.com

You can disable rendering of polygons/areas in the QMS user interface. Just click on the triangle in front of the map in the “View” tab. Then you will see some check boxes that allow to disable/enable rendering of areas/lines/points.

I downloaded a map from BBBike and get the same red rash. It appears that the IMG file does not contain an embedded TYP file. Therefore the map is displayed with some QMS default style. Maybe you should contact either BBBike or QMS developpers on that issue. You could also look for some TYP file and load it QMS. This can be done at the same place as the polygon disabling. There are also tools for extracting the TYP file form maps that have one embedded.

Thanks for pointing out that option. I am using the Garmin .img file in Qmapshack. Possibly the Garmin .img does not support a type file? I can’t find much information on the Garmin file format.

– The only difference between men and boys, is the price of their toys.
http://wb8nbs.wordpress.com

I don’t think that, you and I tried as far as I know the exact same .img file and I did not see these red rash in QMapShack.

I would try deleting (or renaming) the complete ~/.config/QLandkarte directory and the ~/.config/QMapShackrc file.

Just to add a general comment about QMapShack, I use it quite a lot when testing changes the the Garmin maps I create.

To be honest, it’s not really a great indicator of “how something will appear on the device itself”. I haven’t tinkered with the QMapShack settings, and at low zooms I see that red colour for landuse=residential with these maps, but if I zoom in it disappears. Source style for that is here.

I also see the red hash disapear at high or low zoom levels. The Etrex 10 display is not a problem, residential areas don’t seem to be marked. It is the QMapShack screen that I’m trying to eliminate red hash. I’m using QMapShack to record my bicycle journeys.

So I gather if I had a .txt version of the QMapShack default type file, I could edit out Residential and compile with mkgmap. Do you know where I could find a version of the default .typ in text form?

Deleting (I renamed) the .config/QLandkarte directory did not change the display.

Okay, good test, that rules out wrong settings.

I would consider opening an issue at Issues · Maproom/qmapshack · GitHub

I think that that’s the wrong question. It sounds like you want to create a map for QMapShack that does not have this line** in it (or maps it to some other Garmin thing).

To be honest, in my experience the representation of residential landuse is a minor problem compared to (say) the prepresentation of various shop types in QMapShack. I did think about one point about creating a QMapShack-optimised mkgmap style, but I decided it was not worthwhile because I wouldn’t use it much (so much would not appear).

** you’ll need to find the corresponding line in the map style you’re using, of course.