Where Potlatch needs to be improved

Here I’m trying to summarize the most hindering drawbacks of Potlatch as I’ve experienced while using it. Though I scanned the forum for “Potlatch”, I’m not sure, whether any item already has been discussed except #1. Hopefully my feedback will lead to an improvement of Pl.

**1. Erroneous import of gpx tracks
While tracking on bicycle I only switch on and off tracking. Thus I can track without stopping cycling. The result, when reading in the tracks to Mapsource are single Tracks named ACTIVE LOG – ACTIVE LOG 01 …. ACTIVE LOG nn, each of which representing a cycle between ON and OFF.
In Mapsource the tracks are displayed correctly. When writing the gpx, Mapsource creates adequate tracks in the gpx.
Reading in the gpx into Potlatch, the subsequent tracks are connected to each other.
This looks like this.

In the German OSM forum we discussed this problem comprehensively
There I found out, that this interconnection is omitted, if the tag of the last track-point of every track is being removed. The same gpx as above then looks as follows.

Attention: this method causes Potlatch to remove the track point with missing tag. Also, after logout and new login, the tracks again are interconnected. We discussed, to save the tracks singularly each in an own gpx file and enter them zipped in Potlatch. This method proved not to prevent the problem.

Request: Independent tracks must be treated as independent tracks and never be interconnected.

2. Translating tracks automatically to ways

Automatic translated tracks first are displayed in red colour. I didnÂ’t manage to find out, what operation is necessary that potlatch recognizes those ways as real and worth, being saved.

  • I connect those ways to other existing ways – the colour stays red.
  • I define those ways as highways – the colour remains red.
    This all ends up, that suddenly, the red coloured ways are disappeared, while my connections attached to those ways are hanging in the air.
    Request: a defined operation to get the red coloured ways to real ways, worth being saved.

3. Definite saving
Most Potlatch users may have made the experience that former work suddenly has disappeared and no history point is available for restore. Nearly all the time there is running a clock, telling “saving data”. I cannot imagine what huge amount of data this thing always is going to save. Especially since a new very quick database seems to be in use. Often I experience that it has saved nothing. And often it also tells me that is has performed an error and that I shall tell someone what crime I have done.
Request: A button to explicitly save a current state and create a history point. After successful save a feedback like: Sir, your precious work has been safely saved for further access, your obedient servant Potlatch.

4. Invisible interconnections
How often have I verified, that ways I tried to connect to each other actually werenÂ’t connected. Or, that ways unintentionally were connected to other objects like rivers ore railways. Unfortunaly, Potlatch offers no visible proof of existing interconnections. Sure, you see, whether there exists a point where the objects touch each other, but the point doesnÂ’t tell anything about real connection. The only reliable proof is, to move a way and to look, whether a suspicious object also moves
Request: Potlatch must make interconnections visible. E.g.: when highlighting a way, display connected points in blue colour.

Can you give me the id of a track where this occurs, please?

“Locked” (red) tracks can be unlocked by clicking the padlock by the way number. It mentions this in the documentation at http://wiki.openstreetmap.org/index.php/Potlatch/Primer#Working_with_GPS_tracks . If it’s not clear in the documentation for your language, please do change the wiki page. :slight_smile:

There will be an explicit save button in due course but it isn’t easy (there are extensive discussions why in the mailing lists). However:

The database might be as quick as Roger Bannister, but if Potlatch sends it a request and it doesn’t respond, there is not much Potlatch can do. That is what “saving data” means - Potlatch has sent a write request to the server and the server hasn’t responded yet.

There are still some performance issues with the database, and also with memory leaks in Rails (the code on which the server runs), which means that some responses get lost. In addition, Potlatch only has very limited control over the interaction with the server - only that which Flash Player gives it. It is not possible, for example, for Potlatch to set a short (say, 10 second) timeout. I wish it was!

If there is an error please do send the error report to the e-mail address given (i.e. me). This is very important. The information it gives is very useful; bugs can only be fixed if you report them and say what you were doing at the time. It almost certainly isn’t your fault, no-one is saying that, but nonetheless if you want it fixed you do need to report it (or fix the code yourself :slight_smile: ).

Meanwhile, if it seems stuck, just click the ‘Edit’ tab again to continue your work. (I find it useful to use browser tabs for this.)

This will be fixed in a future version.

Hello Richard,

Hopefully this is the id you need:
The file has been modified in Mapsourse and pspad: tracks were renamed, reorderd, the tag of the last track points removed.
The reordering had the consequense that the tracks were connected in the new order.

Fine, that you tell how to unlock locked ways. Due to my impression they should be unlocked automaticaly as soon I connect them elsewhere.

That I didn´t report error messages has a simple reason: I could not verify what operation actually caused the message.
best regards,

I think that track must not be public - I can’t see the data. Could you make it public, please?

Regarding “invisible interconnection” → do you know when it will be fixed? I hear that it will be fixed in future since more than 6 month, and routable maps will never work well as long as Potlatch users destroy connections because they can’t notice whether a node is connected or not. If any node connecting different polylines would show up in another color, that’s all what’s needed. Can’t be magic, can it?


Alternatively there existst also this trace, containing only two tracks wich were submitted in two gpx files zipped into one zip.


Richard wrote:

Well, perhaps my feedback gives you arguments in the following direction:
It seems to me, that there has not been installed a correct priority handling on the server.
Edit tasks like Potlatch or JOSM have to be served with highest priority possible other than real time priority. These are the tasks, where data losses imply loss of real work. And these are the tasks where people are waiting online for server response. All other tasks like map display or map generation should have to wait behind those important tasks being served !

Thanks for linking R. Bannister. Was nice to learn about him. You may understand, that running miles is not that popular in Germany, especially since it is not an Olympic discipline.
Have you ever heard of Armin Hary ?
He was the first to run 100 m within 10.0 s. It was often said, if at that time, electronic stopwatches were in use, he would have been the first to run the 100 m under 10 s.

What will happen then ? Do I have to stop working until you have finished analyzing ?
The only thing I can see is the error message, but Potlatch still continues running like nothing has happened. And: Potlatch only says, that an error has occurred, but gives no hints what kind of error (as I remember, since I’ve currently stopped working).

You are right, actually in German translation it sounds quite different than in the original. IÂ’ve read several times the according sentence and tried to find a padlock before I had to deal with the locked ways. When I had the problem, I didnÂ’t remember that sentence to be valid just this very moment.
And once again: The way should be unlocked automatically, as soon as it is connected somewhere else. Nobody will try to connect an irrelevant way. And if he does und doesn’t realize the error, he is a fool. A fool who also is able to unlock the way unintentionally.

If it’s so easy, why haven’t you fixed it yourself? :stuck_out_tongue:

But seriously, this is what’s open in another tab on my machine right now:

I’m no expert on the server (if you want a more authoritative answer you should ask on the dev@ mailing list), but - they are already served with a higher priority. See http://trac.openstreetmap.org/browser/sites/rails_port/config/lighttpd.conf - all the ‘write’ operations are served by /dispatch.api, whereas more of the ‘read’ operations are served by /dispatch.bulkapi which has a lower priority.

There are still some problems - in particular, Potlatch’s write operations will sometimes be carried out but not return a success code to the Potlatch client. We have really good guys working on the server and the problems that have arisen with API 0.6 will be ironed out in time. But these are not simple things to fix.

Many of the problems have historically come from memory leaks in Rails and associated libraries (particularly the XML ones), and Rails is a. not our codebase and b. not that easy to debug! If you look through various mailing lists you will see our sysadmins are actively fixing bugs in other people’s code where necessary - e.g. http://www.mail-archive.com/libxml-devel@rubyforge.org/msg01330.html .

I hadn’t but I shall go and have a look now. :slight_smile:

:slight_smile: No, but I can’t fix the code if no-one tells me about the error! There appears to be a bug in the Potlatch client at the moment that shows up sometimes when splitting ways; this causes the “node -3 not found in way” -type error. But thus far I can’t reproduce it. If you can find consistent steps to reproduce then that would be the single most helpful thing.

I’m afraid I don’t agree. If you make ways unlock automatically when they’re connected to another way, then people will start using that method to unlock ways - even if they didn’t want to create a connecting way in the first place. So you’ll get unnecessary ways created.

There is already a good method to unlock a way: click the padlock. That you didn’t realise this appears to be a mistake in the German documentation, not in Potlatch. But then, the next version of Potlatch will have greatly improved documentation built in, and if I can stop answering forum questions for five minutes I might have a chance to finish it this week. :wink:

Thanks for the comments as ever.

Thanks - I’ve used this to find and fix the issue. Will be live in the next version of Potlatch (hopefully some time this week).

Okay. that looks great. Will this only apply to ways that are selected or all ways? the square node would be good on all intersections, be they active or not IMHO.

I’m really awaiting it.

Both the selected way and any that you mouse-over while drawing.

Separate choices of features for open-ended ways and areas would be useful.

Sorry, what do you mean?

What I mean is that if the points defining a way close in at the end the way is likely to be the outline of a land area or building and unlikely to be a road (except roundabouts). On the other hand a way that doesnÂ’t join back to itself is going to be a road, path, railway line or something similar and couldnÂ’t be the outline of anything. If you distinguish between the two you can offer a decent choice of options for both cases without overwhelming the users.

Surprisingly today I found the new version of Potlatch with the promised modifications.
Thanks a lot, for me Potlatch is now much more useful.
Good: Tracks now correct, junction points now good visible
Not so good: Offline mode not as sure as expected.
Question: Unlocking many ways is tedious. Couldn’t there be defined a shortcut ?

Gibuld - you can press ‘K’ to lock or unlock a way.

Wynndale - so if I read you right, you’d like a different set of presets for areas (closed ways) to normal ways? I can see the logic but I’m not sure it works for all users. For example, I tend to add tags when I start drawing a way, not when I’ve finished. I wouldn’t be able to do that if Potlatch only presented the “open way” tags to begin with.

If you run Potlatch with separate save and you then switch your browser to another tab your edits are lost without warning. I have just lost 45 minutes of work that way.

What browser/UI? I’ve never experienced that.

You should be saving every five minutes anyway, not every 45!

I was using IE7 (the only Flash-enabled browser where I was working). I was using the ‘Edit with save’ mode and I hit the History tab button (not the browser tab). When I went back to ‘Edit’ Potlatch restarted and downloaded the area as it was before I started editing.