water ditches suddenly are black lines and rendering oddities

Noticed the last day or so or some reason the maps are reverting in areas and different zoom levels to what the display was months ago. Is there something going on since I haven’t seen any information on this. Furthermore, it seems water ditches has suddenly become black lines, it seems really odd and not sure if anyone else has seen this. I do notice there is a part that was a culvert that wasn’t changing.

Not sure if there is some sort of update going on that could explain what is going on or server maintenance.

Perhaps you could link to the area concerned - that way people might be able to see what the problem was.

There’s been some recent discussion at https://github.com/gravitystorm/openstreetmap-carto/issues about ditches being too prevalent at some zoom levels, but I don’t think that a change in that area has been applied yet.

I suspect that the most recent functional change to the “standard style” was https://lists.openstreetmap.org/pipermail/dev/2017-May/029876.html ?

Maybe also have a look at other available map styles to see if there is one that works better for where you are?

I think he is referring to: http://www.openstreetmap.org/way/489656937 and http://www.openstreetmap.org/way/489656939

Thanks for noticing. The problem with waterways is known and a fix is under way: https://github.com/gravitystorm/openstreetmap-carto/pull/2636
Other issues you describe might be the tile servers rendering the new style and working through the queue as there were some problems with a rendering server in the past.

I have noticed some rendering issues before as well, and that the further zoomed out levels haven’t updated in months. It is strange seeing how random areas at different zooms revert to that old rendering. Especially noticable in the area I have worked since I’ve mapped out large areas around me since late January when previously almost nothing was mapped and some errors. The area around 38,55, -91.00 is where i’ve worked so you can really see the odd rendering issue. The ditch thing really stands out in agricultural areas and that the previous rendering gave a good impression of it being an intermittently filled with water ditch

Another related thing I noticed is that it seems plant nurseries now show up on the standard map. There was one I mapped some time ago at 38.59563/-91.00335 that with this update now is visible. Not sure if other features that weren’t rendered are now so. May have to browse the wiki to see what updates on the legend there are.