Using osm-bundler on Ubuntu


I’ve read this wiki.
So I was just interested how it work but for me it didn’t work.
Python is already installed on my system.
Installing of PIL also worked. (testet with python selftest build)
Installing libgfortran3 also worked.
Export of path for worked.
Trying to start osm-bundler worked (showed the help)
Starting with list of example photos crashed… :frowning: Any ideas?

python --photos=list.txt 
Working directory created: /tmp/osm-bundler-wG6y5m
BundlerMatching executable path: /home/myubuntu/osm/osm-bundler/software/bundler/bin/KeyMatchFull
Sift executable path: /home/myubuntu/osm/osm-bundler/software/vlfeat/bin/glx/sift

Processing photo 'IMGP3417.jpg':
    Copy of the photo has been scaled down to 1200x900
    Extracting features with the SIFT method from VLFeat library...
Traceback (most recent call last):
  File "", line 9, in <module>
  File "/home/myubuntu/osm/osm-bundler/osmbundler/", line 134, in preparePhotos
  File "/home/myubuntu/osm/osm-bundler/osmbundler/", line 176, in _preparePhoto
  File "/home/myubuntu/osm/osm-bundler/osmbundler/", line 244, in extractFeatures
    self.featureExtractor.extract(photo, self.photoDict[photo])
  File "/home/myubuntu/osm/osm-bundler/osmbundler/features/", line 16, in extract[self.executable, "%s.jpg.pgm" % photo, "-o", "%s.key" % photo])
  File "/usr/lib/python2.7/", line 486, in call
    return Popen(*popenargs, **kwargs).wait()
  File "/usr/lib/python2.7/", line 672, in __init__
    errread, errwrite)
  File "/usr/lib/python2.7/", line 1213, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied


Something is wrong with permissions. Unfortunately I don’t have Linux.

In general, if you want to extract building outlines from photos, I’d recommend you to use OpenStreetMap Plugin for Google Sketchup.
Though I’m not sure if it works on Linux

Hi Martin,

I’ve tried osm-bundler under linux-mint 11 and I finally got it to work.

My first problem was installing PIL with jpeg-support.
The following link helped me:

Second problem was the permission-problem you described.
The solution is, to change the permission of the files in the subdirs of osm-bundler/software/ to executable.
In special the following command changes the permissions:

chmod +x software/bundler/bin/Bundle2PMVS software/bundler/bin/bundler software/bundler/bin/ software/bundler/bin/jhead software/bundler/bin/KeyMatchFull software/bundler/bin/ software/bundler/bin/RadialUndistort software/bundler/bin/ software/sift-lowe/sift software/vlfeat/bin/glx/*

The third problem was something like “libgfortran could not be found”. Even though i installed the package.
I solved it in a very quick and dirty way:
I downloaded the amd64-deb package from and unpacked the file to software/bundler/bin/

Hope I could help you.

Greetings, Falko

Hi, photogrammetry seems to be interesting to get 3D models but currently there is no easy to use tool out there?
I guess this has to change if we want even non 3D aware novices to contribute models :confused:


Google Sketchup with its photo matching tool and OSM plugin seems to be a more practical approach.
There is a special topic at this forum