Uploaded Track is deleted directly


I need help. Today I already tried 3 times to upload a new track. The upload worked and it was also written: PENDING
After refreshing the page my track has gone. A further upload did not help - Same problem.
Could somebody help me?

Further more I would like to know how I save an edited map. Yesterday I painted new streets in my little village. But till today they dont appear in OSM :O(

Thanks in advance

Don’t know about first part of your question but for the second part, the default map you see is the Mapnik one and is only updated once per week, if you switch to Osmarender using the blue plus sign at the right of the screen you should see your updates now although the time to update varies.


on the first part of the question by atua:

You should receive an e-mail on the e-mail address you provided with registering on OSM. If the upload is unsuccesfull, it should mention there why. Simple items you can find out yourself, many people around who know how to solve the complex issues

Common errors with GPX files

  1. it’s not GPX
  2. it doesn’t have time
  3. it doesn’t have ele? ← not sure might be old assumption

I have the same problem with the track upload. Traces are listed as pending after upload, but they’re gone after reloading the site. There is no error message nor success message, or an email.
The gpx files are valid as all my other files I uploaded before. I just convert my tracks from nmea to gpx with routeconverter - haven’t updated it or changed settings.
Was there an update to the upload service last week?

Ok I tried uploading a fake file and I did get an email back. So try again if it doesn’t work report it on trac.openstreetmap.org

So do others as the public traces list is growing.

Thanks for the hint, I have opened ticket #1335

Try using this to upload NMEA directly, rather than routeconverter: http://richard.dev.openstreetmap.org/upload.cgi

Most upload failures are because there are no timestamps.