Uploaded trace not shown in iD editor any more.

I have uploaded a gpx trace to OpenStreetMap. I can go to the GPS traces and choose to edit the trace I uploaded. The editor starts, positioned at the right starting position, but the trace is not shown in violet as it used to be. I cannot see it at all.

What has changed?

If I drag and drop it from a local directory onto the map everything works fine.

Which editor are you using? It sounds like you’re using the flash-based editor Potlatch 2, and I’ve certainly used that to edit uploaded traces since you asked this question. Does the problem happen with any new trace that you upload? Can you make one of those traces public so that other people can see if it works for them?

He’s talking of iD, i think: “Uploaded trace not shown in iD editor any more.”


Well - you learn something every day!

Initially showing an uploaded GPX traces wasn’t included when iD was introduced, and there was that separate overlay layer instead (that worked some of the time, with caveats).

I’ve just tried editing a trace of mine (with iD) and I can see a purple trace for it.