Upload always fails (incorrect password or username)

Hi everyone,

i always get this error message when i try to upload my osm file out of JOSM.
My login works fine on the website, i can upload and edit my gpx files.
I’m using JOSM version 889 and openSuse 11.0.

I tied to login both with my nickname and my email adress. None of these works :frowning:
I also did a short capture with wireshark and it seems that my login data isn’t transmitted at all! Neither the username nor the password!
Or is it transmitted encrypted, although it tells me it won’t?


The best thing would be to send a email to the josm-dev mailinglist, including a copy paste of the java console.

Also did you tried to install the newest version or the more of less stable version on josm.openstreetmap.de?

I now also tried versions 897, 815 and the 1.5.
Is it correct that version 1.5 uses a server API (0.4 i guess) which is not supported any more?
I also did shutdown the firewall but without effect.

Is there any little stupid thing i did not see? That my account is not the one i need for uploading files although i can login on the osm main page and upload tracks?
Is it because i use java version 1.6.0?

I think i’m gonna post it on the dev mailing list as you supposed if no one has any further hints for me!


Java 1.6 should work AFAIK, also i doubt you got a version for API 0.4. Anyway 897 815 etc. should work for api 0.5 ( changeover for API was last year). Also you use the correct account, as the only other account for OSM you can get is for the wiki. The account for uploading changes is the same as the one for this forum, uploading tracks and the main osm page. So that is also not the problem. But do you use a proxy server? You will have to set this up for JOSM in java, instructions for this on the wiki somewhere ( it is down now, otherwise i would have looked it up for you)

I’m not using a proxy, just a normal WLAN-AP including a DSL modem.

I’ll now do a post on the trac and report as soon as i got it working!


in ~/.josm/preferences I have:

I just checked the file and found out that he mixed up the “y” and the “z”.
When i type in a “y” in the password field, it is saved as “z”!
So i just entered my password with “z” and everything works fine now!

I also opened a ticket for it and hope im gonna get an answer to this.
I’m just wondering because it seems i am the only one who has this problem ?-|