"Unable to geocode" in Nominatim

Hello Team,

I have launched nominatim service for “europe”(europe-latest.osm.pbf) and successfully installed and running fine.
I did “reverse” geocoding for the the lat=48.0208384 and lon=10.28653680883767 but got the response “Unable to geocode”
But if I do the same in public nominatim (nominatim.openstreetmap.org/reverse?format=jsonv2&lat=48.020705&lon=10.287473](https://nominatim.openstreetmap.org/reverse?format=jsonv2&lat=48.020705&lon=10.287473)) and able to do geocode and print the result:
“place_id”: 111489455,
“licence”: “Data © OpenStreetMap contributors, ODbL 1.0. OpenStreetMap”,
“osm_type”: “way”,
“osm_id”: 110470839,
“lat”: “48.0208384”,
“lon”: “10.28653680883767”,
“category”: “building”,
“type”: “yes”,
“place_rank”: 30,
“importance”: 0.00000999999999995449,
“addresstype”: “building”,
“name”: “”,
“display_name”: “12, Am Heilig Kreuz, Unterwesterheim, Westerheim, Erkheim, Landkreis Unterallgäu, Bavaria, 87784, Germany”,
“address”: {
“house_number”: “12”,
“road”: “Am Heilig Kreuz”,
“neighbourhood”: “Unterwesterheim”,
“village”: “Westerheim”,
“municipality”: “Erkheim”,
“county”: “Landkreis Unterallgäu”,
“state”: “Bavaria”,
“ISO3166-2-lvl4”: “DE-BY”,
“postcode”: “87784”,
“country”: “Germany”,
“country_code”: “de”
“boundingbox”: [

What is wrong with my own nominatim instance which can not geocode but public do?
I have launched the nomiantim via docker and find the docker run command below

docker run
–log-driver json-file
–log-opt max-size=10m
–log-opt max-file=3
-e PBF_PATH=/nominatim/data/europe-latest.osm.pbf
-e UPDATE_MODE=continuous/once/catch-up/none
-e FREEZE=false
-v nominatim-data:/var/lib/postgresql/14/main
-v /osm-services/bremen/nominatim_db/:/nominatim/data
-v /osm-services/bremen/nominatim_db/:/nominatim/flatnode
-p 3001:8080
-i -t -d
–name nominatim_europe_3001

It’s better to ask the question on mediagis/nominatim-docker · Discussions · GitHub because more users of Nominatim read it.

You didn’t mention if this is the only address that doesn’t work or if none of the addresses work.

The setup looks alright, I’d say the import didn’t finish. Can you run nominatim admin --check-database ? Check the Nominatim docker documentation how to run that inside the docker container.

-e UPDATE_MODE=continuous/once/catch-up/none

Here you need to select one of the 4 options, not all 4. Not sure which one got applied. It’s unrelated to reverse search though.

Thank you @mtmail
I did one mistake while configuring(although it was not mentioned in docker git hub also)
I have created a directory to mount the postgressql data to “/var/lib/postgresql/14/main” but failed due to no permissions. Changed the permissions also but still failed.
So mounted that volume to “/mnt/” and run the docker again. Now it is doing indexing propelry.
Hope it will work properly