Tutorial asks user to type point category that does not exist (cafe)

I’ve gone through the tutorial, and everything worked well until it showed me what “Points” are. I selected the point it told me to, which opened a category search. The tutorial asked me to search “Cafe” (no diacritic) which I did, and Cafe is not one of the options. I tried searching “C”, “Ca” “Caf” and the lowercase variants.

I’ll just skip to the next step (I’ve already edited before via Organic Maps), but wanted to let project maintainers know, and couldn’t see any dedicated bug area in the forum.

1 Like

Ok, I tried to debug it some more.

I then realised that it was because I clicked on the highlighted red border of the building, because that highlighted very obviously in red when I moused over it, so I thought it was showing me that I would select the location by clicking the border.

If I instead click the middle of the building, where nothing highlights (no feedback) then in the category search, “Cafe” is an available option.

This could be improved in two ways:

  1. Adjust the tutorial text to specifically call out that the user should click the center of the building.
  2. If the user clicks the border (which is some different action, I think to select the building as opposed to the space within the building?), then close the walkthrough, and show a button “Take me back to the walkthrough”, as leaving the user in the walkthrough but asking them to search for a category that doesn’t exist will likely bounce many users.

Hm, there is some unfortunate misunderstanding going on.

When I create a standalone point (as was the point of the tutorial), Cafe is indeed an option:

However, instead of creating a new one, it seems you selected one of border points of a building. We don’t usually tag those, except for some specialized stuff (such as “entrance”), so you did not get Cafe as an option. As you discovered, the whole building can be tagged instead.

For the avoidance of doubt, “cafe” is suggested as an option when you add a new area and search for “caf”. I’ve just added this as a test on the dev server.

1 Like

Sure, but all of the helpful context that enables an experienced user like you to understand how clicking the border of a building won’t bring up the cafe tag as an option isn’t available to a new user doing the walkthrough.

For a new user, the definitions of these terms are vague - that’s why they are doing the walkthrough!

When the border of the building is selected, the walkthrough proceeds to the next step and asks the user to mark the building as a cafe.

This shouldn’t happen if as you say, a border can’t be marked as a cafe. Perhaps the user should be stopped from doing this, with a dialog explaining they have selected a border and instead need to click on a point within the building. Or, if they select anything but a point in the building, close the walkthrough and tell them how to reopen it.

Telling the user to do the next step when it is literally impossible (because they selected a border) doesn’t make sense.

This post isn’t “Someone please help, I can’t get past the tutorial!”, I’m instead trying to communicate “I figured this issue out, but some users might not, here are ways it could be improved.”

1 Like

Thanks for clarifying. In turn, I was only pointing out what the actual functionality is, not criticizing you for failing to follow the steps. It’s a bit hard to figure out which steps the walkthrough proposes without running it myself.