Strange (buggy) routing with routable map

I have just downloaded the Garmin routable maps for my neck of the woods, and by and large they produce good (or at least reasonable) routes. But yesterday I was driving down I93 from New Hampshire to Boston when the GPSr wanted me to leave the highway, go round a roundabout, and immediately return to the highway. I obviously ignored it.

I have created two waypoints with MapSource, one on either side of the exit, and on my computer it produces the same strange (to say the very least!!) route. The two waypoints and the route between them should be available here … unless I have somehow failed to make the file readable to anyone with a link :slight_smile:

My guess is that the problem is in the data, but I really do not know enough about the routing parameters to check for myself. Would be grateful if someone who understands how this works had a look at it!

Its easier to find the problem if you post a permalink (bottom right corner of OSM screen) to the location. If you change the lat & lon parameters to mlat & mlon it will stick a marker on the OSM map.

I’m sure that there are plenty of routing errors in the US: although most interstates should have been reviewed by now. MA is a special case because the MassGIS data was imported by town/city rather than county as for everywhere else in the States. This means that there are more potential cases for duplicate nodes (two nodes in the same place, which may need to be joined).

All roads seem properly labelled and connected. The only thing I fixed was to add a layer key to a bridge, but that is irrelevant here.

The only thing I can think of is that the I-93 has a max speed tag, whereas the other roads don’t. I don’t know whether this finds its way into the Garmin .img file or not. I don’t have US tiles here, so I can’t easily check that, but the best course of action would be for somebody with GPSMapEdit to open the tile and take a good look at the properties of this piece of road.

I should have thought of the permalink, though I did not know the “mlat/mlong” trick; thanks for telling me about it :slight_smile:

Here is the link; directions were to exit at the marker, go round the roundabout, and return to the highway :frowning:

I tried routing through here using and it routed as expected. Still no clearer to seeing what’s causing the strange Mapsource/GPS behaviour.

Many thanks for the link to!

Has anyone downloaded the GPX file linked to in my original post and confirmed the strange behavior that I observed? I am asking because I have run into another apparently inexplicable routing (on both my MapSource and my GPSr) that routes perfectly normally on