[SOLVED] [JOSM] NOK uploading bunch of waypoints I recorded ?


This is the first time I’m 1) using a Garmin GPS device to record a bunch of homonegenous waypoints (ie. of the same type) and 2) editing + uploading them to OSM from JOSM, so I’d like to double-check before I break things.

Here’s what I did:

  1. Used Garmin GPS device to record waypoints of identical type

  2. Started JOSM

  3. Opened GPX from Garmin

  4. Converted to data layer

  5. Selected all waypoints, removed useless tags, applied relevant tag to all waypoints

  6. Saved file

  7. File > Upload Data: “Upload Discouraged: You are about to upload data from the layer “mylayer.osm”. Sending data from this layer is STRONGLY DISCOURAGED.”

What’s a girl to do?

Thank you.

By default, layers created from GPX files have the “Discourage upload” flag set, because generally you wouldn’t want to blindly upload the contents of a GPX file. Rather, you should download the relevant area from the OSM database and integrate the new data into that. Otherwise, you may upload an object that already exists in the OSM database, creating a duplicate. You’d also want to check to ensure that the objects are at the correct position. GPS devices aren’t perfect. If you download the existing data and integrate your new data into it before uploading, you’d be able to check for waypoints that may have been a bit off and are now inside a building, are on the wrong side of the street, etc.

If you’re absolutely 100% certain that none of the above issues exist, you can right-click on the data layer in JOSM and click “Discourage upload” to toggle the flag off. However, the preferred method would be to download the existing data and add your data into that just to be safe.

  1. Download the whole area from the OSM-Database into a new layer
  2. Adjust / Delete your GPX-Points in the first layer according to the content of the OSM-Layer (nodes migth already exist etc.)
  3. Combine both layers and upload,


After zooming into the small city I’m working on, and hitting File > Download from OSM, JOSM complains with:

So I zoomed on only one part of the city where I gathered waypoints, and it did download data successfully.

However, although I expected something like Mapnik, this is what is displayed:

I can’t even see my own waypoints :-/

How can I check if any waypoint was already uploaded to OSM ?

Thank you.

In the layers-pane on the upper right you should have 2 (data-)layers: you converted GPX-Points and the downloaded database area.

You can tweak the display of each layer: https://josm.openstreetmap.de/wiki/Help/Dialog/LayerList

As sent to you in a private message

  • use the JOSM filter functionality to hide everything besides the type of objects you need
  • or download only the types of objects you want to download in an area via Overpass (from OverpassTurbo or via the buildin Overpass functionality of JOSM

Also check the style settings of the default mappaint style. See https://josm.openstreetmap.de/wiki/Help/Dialog/MapPaint/StyleSettings

“Less obtrusive nodes at low zoom” and “hide icons at low zoom” should be checked for better uncluttered mapview on low zoom like in your screenshot.

Thanks everyone.