Solved: JOSM --- cannot show satellite images other than bing


I tried to show other satellite images than bing using e.g. menu “Imagery->Mapquest Open Aerial”, all in JOSM. I get an additional layer “MapQuest Open Aerial”, but there is no satellite picture, it’s black. After some time I get the message “Error: Problem loading tile” at several places in this picture.

I’ve not found any zoom level where it works, and I’ve not found any satellite except bing, where it works.

Anybody who can tell me what I’m doing wrong? Or provide any link?

Many thanks

Bicycle Tourer

P.S.: I’m using version 14178

The reference to MapQuest Open Aerial suggests you may be using a (very) old version of JOSM. The Current version is 14178 (from the Help|About menu). Might be worth checking.

Many thanks for the answer. I’m using exactly this version 14178. Is it possible that JOSM has some configurations built in, which are not updated? I started 5 years ago with JOSM, and had a 4 years interrupt, not doing any work on OSM. But I updated JOSM first when I restarted these days. So the idea of an old “configuration”. As a background: I’m not aware that I’ve ever done any configuration to the way I used JOSM, always used the default and “as is”. To give you an idea what the imagery menu shows:

Reorder imagery layers [greyed]
Imagery preferences
Imagery offset

bing sat
DigitalGlobe Premium Imagery
DigitalGlobe Premium Imagery [yes, again!]
Esri World Imagery
Esri World Imagery (Clarity) Beta
MapBox Satellite
MapBox Satellite [yes, again!]
MapBox Satellite [with another icon]
Mapquest Open Aerial
OpenStreetMap (Mapnik Black and White)
OpenStreetMap (Mapnik)
OpenStreetMap (Mapnik) [yes, again!]
OpenStreetMap (Standard Black and White)

Bavaria 80cm
Deutsche Bahn VzG lines 2017
Deutsche Bahn VzG lines 2015

Recitified image…

Many thanks in advance

Bicycle Tourer

What version of JOSM are you using?

14178, the newest.

Go to the Imagery preferences and click the blue reload button on the right side. That will updated all default entries. Maybe that helps.

Hi all together,

the issue is solved. I had very old links in my selected preferences. Deleting the old ones and selecting newer ones instead (from the list of available default entries) gave me back other satellite images. All in the imagery preferences.

Many thanks to all who provided pieces that led to this overall solution.

Bicycle Tourer