Resolution of railway stations in mkgmap

As far as I understood, not every type of point responds to the “resolution” setting within the points style file for mkgmap.

Railway stations (code 0x2f08) for example disappear at zoom levels higher than 500 m, even if the resolution value in the points file is lowered. This is a problem, because one might want to find a railway station at low resolutions like 2 km.

A solution could be to use a diffent code and define a railway station icon in the typ-file for this code. But only some point codes seem to have the ability that their symbols are shown at lower zoom levels (at least on my eTrex Vista HCx). I have tested the following on the eTrex with mkgmap-r2049:

0x2100 : visible at lower resolutions, but a long word (“Anschlussstelle” in german settings) is written in front of the stations name
0x4500 : visible only up to 500 m
0x1200 : visible only up to 500 m
0x9000 : no name is shown on mouse hover

Does anyone know a (free) point code, whose simbol can show up at 2 km zoom and shows the points name when touched by the mouse?

What level is your “resolution” set to, 22? That should stop displaying at 500m. Are you saying that if you set the resolution to 20 or 18 railway stations still stop displaying at 500m?

Yes. I have tested resolutions 24, 17, and 10. In all cases the railway stations stop displaying above 500m.

BTW: In the options file there is a line levels = 0:24, 1:22, 2:20, 3:18, 4:16 that I left there although it seems that it is not used by the rest of the stylefiles.

That line defines how many layers of resolution are explicitly created by mkgmap and saved into your IMG file, as opposed to calculated by interpolation on the fly by your GPS or Mapsource.

Resolution 24 wouldn’t work, because that would only show up on level 0. (Highest Resolution)
Resolutions 17 and 10 aren’t defined in your map style.
Try Resolutions 20, 18, and 16. They are defined in your list above.

Also be aware that some Garmin units display a line using a garmin default railway line-code only at certain levels regardless of the display level set for this line in the map!

You can try to use pois of cities, which are displayed at lower zoomlevels. Disadvantage is that the search results of places will contain railway stations, but this can be seen as an advantage too :wink:

I’m have a similar problem and am getting a bit confused.

I’m using the Mapnik new style and typ files from

The “drinking water” POI is visible up to 800m.

However the “toilets” POI disappears above 80m zoom. (Garmin Edge 800 gps).

I want the “toilets” POI to be visible at lower res zooms similar to the “drinking water”.

What do I need to change to get this to happen? :smiley:

A bit more info:

From Options file:

levels = 0:24, 1:22, 2:20, 3:18

From Points file:

amenity=toilets [0x2f1c resolution 24 default_name ‘Toilets’ ]

amenity=drinking_water [0x5000 resolution 24 default_name ‘Water’]

Why do toilets disappear at zoom out past 80m while drinking_water stays visible until 800m?

Garmin has decided to render some pois only at the highest zoom to prevent cluttering.
This is firmware dependend and cant be controlled by mkgmap.
So if you want to change it try another type, maybe 0x5001?

Are great, that explains a lot. I’ll give it a go. Thanks again. :smiley:

Thanks ligfietser that worked fine. :smiley: