Rendering italy.osm map on Gosmore

Hi everyone,
I’m trying to view my osm xml file in Gosmore. It’s not the “planet.osm” but the smaller “italy.osm”.
I try to run gosmore with the command

 cat italy.osm | /home/fabio/gosmore/gosmore rebuild

as explained in the wiki page. everything seems to work until here.
When it finishes the building process, gosmore starts but I can’t see any map, while search field and such are avilable and proper working.
from the shell i get this message:

Either icons.csv or elemstyles.xml not found
/home/fabio/gosmore/gosmore is in the public domain and comes without warranty
(gosmore:6332): Gdk-CRITICAL **: gdk_gc_new: assertion `drawable != NULL' failed

How can i fix it?

thank you


Make sure the Gosmore directory contains icons.csv and elemstyles.xml. You can find those two extra files in Gosmore’s svn repository. Then change the working directory to the gosmore directory and execute the rebuild command from there.

cat italy.osm | gosmore rebuild

the Gosmore folder does contains both files. I then tried again moving to the gosmore directory and executed rebuild command but i get my pc slowing down and then a weird message

~/gosmore$ cat italy.osm | gosmore rebuild
gosmore is in the public domain and comes without warrantee
Reading nodes...
Unexpected tag bound
Unexpected tag bound

and, obviously, gosmore not running at all.


hem, what about Gosmore on a Pocket PC with WinCE?
i put the ‘’ and the ‘gosmore.pak’ on my storage card. it works fine but the map i got from looks pretty “empty”. I mean it is not as detailed and correct as OSM maps are, despite it is the last version, updated on 2009-04-07.

Is there another repository or server where to get something better?

I tried to create the “gosmore.pak” file from Linux, running the command

cat italy.osm | ./gosmore rebuild

so that i can have a .pak file with an well detailed map. and it works perfectly when i run gosmore on linux, but it’s not so good when i try to put that .pak file on my PDA and work with it: no map showed.

Is it possible that a “gosmore.pak” file created with linux can’t work with winMobile?

I’m not sure, but the pak file is a binary format that dependent on the endinanness of the processor. So it is possible that a pak file that is built on x86 does not work on ARM, but I’m not sure of that.

Afaik this is not depend on the operating system.

I don’t know either: But ARM and Mips can use both endian types, I’m guessing Windows Mobile is running using the same endianess as x86.