Ratlosigkeit nach erstem Eintrag

Hallo zusammen,

bitte seht mir die Frage nach, ich bin ein absoluter Newbie bei OSM. :innocent:

Vor ca. einem Tag habe ich mich bei OSM angemeldet, da der Anbieter meines elektronischen Fahrtenbuches den Dienst zur Anzeige der Strecken nutzt und einige Adressen fehlen. Da dachte ich super, dann kann ich ja einfach mithelfen, diese beizutragen. Gesagt, getan.

Ich habe in meinem ├änderungssatz das Geb├Ąude hinzugef├╝gt und die Stra├če verl├Ąngert. Bis vor ein paar Monaten war das noch alles eine Baustelle.

Gehe ich nun auf die Kartendarstellung in OSM, erhalte ich je nach Vergr├Â├čerung verschiedene Ansichten. Auf der folgenden ist das Geb├Ąude und die verl├Ąngerte Stra├če sichtbar, das Geb├Ąude sieht jedoch ein bisschen komisch aus:

Zoome ich ein wenig raus, verschwindet das Geb├Ąude und ein Teil der Stra├če, obwohl mir ein benachbartes Gewerbe noch angezeigt wird.

Eine Zoomstufe weiter raus verschwinden das Geb├Ąude und die verl├Ąngerte Stra├če.

Leider kann ich als Newbie nur ein Bild einf├╝gen, hole das aber bei Interesse gerne in weiteren Beitr├Ągen nach.

In der OSM-Version des Fahrtenbuches wird das Objekt immer noch nicht gefunden, aber das kann nat├╝rlich alle m├Âglichen Gr├╝nde haben.

Nun bin ich ehrlich gesagt ein bisschen ratlos. Die Einf├╝hrung habe ich durchgearbeitet und m.M.n. sollte alles passen. Ich kann aber nicht ausschlie├čen, dass ich irgendwo einen Denkfehler habe.

Falls sich das jemand der erfahreneren OSMler mal anschauen und mir eine R├╝ckmeldung geben k├Ânnte, w├╝rde ich mich freuen wie ein Schneek├Ânig. :blush:

1 Like

Sieht gut aus. Versuchen Sie es mal mit einem anderen Browser. Oder l├Âschen Sie den Verlauf Ihres aktuellen Browsers. Gr├╝├če aus Belgi├źn.

3 Likes

Hallo @nivaOne, vielen Dank f├╝r die schnelle R├╝ckmeldung. :blush:

Das hatte ich auch probiert. Den Eintrag hatte ich mit Vivaldi gemacht, deswegen habe ich anschlie├čend noch mal mit dem Firefox gepr├╝ft, der die Seite noch nicht besucht hatte. Das Ergebnis ist aber leider in beiden Browsern identisch.

Dr├╝ck im Browser mal STRG + F5 an der Kartenstelle.

3 Likes

Hallo Ragnir,
etwas Geduld :slight_smile: . Das dauert manchmal ein paar Tage, bis die Änderung in allen Zoom Leveln dargestellt wird.

4 Likes

4 posts were split to a new topic: Brauchen wir eine FAQ? (Warum werden meine Änderungen nicht angezeigt?)

@milet Genau das warÔÇÖs! Ich musste jetzt zwar auf jeder Zoomstufe einmal STRG + F5 dr├╝cken, aber seitdem wird alles stufen├╝bergreifend korrekt angezeigt. Irre. Warum das der OSM-na├»ve Firefox nicht direkt so angezeigt hat, ist mir schleierhaft.

@Holger-erf Das ist sehr gut zu wissen, dass es durchaus ein paar Tage dauern kann; dann kann ich ja die Panik erst mal ohne Pharmaka im Zaum halten.

Es scheint, als k├Ânnte ich also trotzdem weiterhin unfallfrei betragen, ohne dabei versehentlich das Internet zu l├Âschen. :wink:

Vielen herzlichen Dank an alle f├╝r die Hilfe! :+1:

1 Like

Das hat relativ wenig mit Firefox, Opera, Vivaldi, Chrome oder sonst etwas zu tun, das ist ├╝berall so. Der Browser speichert einfach Bilder, damit sie beim n├Ąchsten mal schneller dargestellt werden k├Ânnen. Im Cache. Mit CTRL+F5 ladest du die Bilder aber neu aus dem Cache. Und dann kommt noch dazu, dass der Server erstmal die Kachel neu rendern muss, was eben auch kurz dauern kann.
In der Kombo gehts eben nicht gleich.

Zur Frage bzgl. dem Fahrtenbuch:
Da kommts dann drauf an, wann der Fahrtenbuchprogrammierer bzw. die Firma die Daten wieder neu von OSM holt. Einmal die Woche, einmal im Monat, den Updateinterwall kennt nur der Apphersteller (oder er hats auf der Webseite bekannt gegeben oder man fragt nach :smiley: )

2 Likes

Weil Browser wie Firefox m├Âglichst sparsam mit Daten umgehen und bei wiederholten Aufrufen einer Seite nicht immer alles neu aus dem Internet herunterladen. Denn das braucht dann nicht nur Daten-Traffic, es kostet auch Zeit.

@Negreheb @Galbinus Alles korrekt, aber da der Firefox noch nie OSM besucht hatte, musste er doch eigentlich auf jeden Fall erst einmal alles laden und rendern. Dass er es danach nicht alle 3 ms wieder macht, ist verst├Ąndlich. Das verbraucht unn├╝tz Ressourcen.

Das mit dem Fahrtenbuchanbieter werde ich mal abkl├Ąren. Darf ich den hier eigentlich nennen oder lasse ich das besser?

Das Rendern erfolgt auf dem Server der Kartenanbieters. Da dieser Prozess ebenfalls sehr aufwendig ist, wird auch dort zun├Ąchst eine Kartenkachel aus dem Cache geholt.

Und da es u. U. mehrere Server gibt holt er auch mal eine Kachel von dem einen und dann vom anderen, also auch mal Effekt, dasse man schon eine neue Kachel hatte und dann wieder eine alte angezeigt bekommt.

5 Likes

Siehe dazu auch die Erkl├Ąrung von @TomH in The "OSM Standard tile layer" looks wrong (white lines, abusive comments etc.) - #32 by TomH
und die Rolle der (derzeit) acht Render-Server.

2 Likes

| milet
April 24 |

  • | - |

Dr├╝ck im Browser mal STRG + F5 an der Kartenstelle.

so einfach ist es anscheinend nicht mehr, weil es auch serverseitige Caches gibt (CDN), darum bekommt man wohl teilweise veraltete tiles angezeigt auch wenn sie schon gerendert wurden, nach ein bisschen Zeit l├Âst sich das aber nat├╝rlich von alleine auf.

1 Like

Auch den CDN Cache kann man mit einem Neuladen ohne Cache (Strg+F5) umgehen und mit den aktualisierten Tiles ├╝berschreiben (nur auf openstreetmap.org), da der Browser dabei no-cache Kopfzeilen mit der Anfrage sendet.

Das kann man auch im Browser beobachten (Beispiel Firefox):

  1. openstreetmap.org
  2. Entwickler-Werkzeuge (F12)
  3. ÔÇťNetzwerkanalyseÔÇŁ Tab
  4. Strg+F5
  5. (optional nach ÔÇťtileÔÇŁ filtern)
  6. Details durch Auswahl einer Tile-Anfrage ├Âffnen

Dort sieht man dann die gesendeten Anfragekopfzeilen Cache-Control: no-cache und Pragma: no-cache, die im CDN den Cache umgehen. Die Antwortkopfzeile x-cache: MISS (statt HIT) vom CDN best├Ątigt, dass die Anfrage an den Render-Server weitergeleitet und nicht aus dem Cache beantwortet wurde.

7 Likes