QlandkarteGT & garmin.openstreetmap.nl .img / .tdb files

G’day folks

I’m totally new to OSM & QlandkarteGT, so I’m probably going to make mistakes here - apologies for noob-ness in advance!

On one machine (the important one here), I’m running 32-bit Ubuntu 12.04.2 LTS, 3.2.0-40-generic kernel, QlandkarteGT (version 1.2.3-1build1), QlandkarteGT-garmin (version 0.3.4-2), and mkgmap-r2567 (downloaded from mkgmap.org.uk today).

On another machine I’m running WIndows 7 64-bit and an up-to-date version of MapSource.

I have generated a download for various bits of the UK via garmin.openstreetmap.nl :

  • the downloaded installer for Windows worked its magic on the WIndows-based machine, and MapSource works like a charm, showing me a routable UK

  • the downloaded .zip containing the .tdb and .img files I tried to upload into QlandkarteGT and yet using the process below I just get a “Failed to load file 63240000.tdb” :

F1 (Map)
F6 (Edit / Create Map)
Source : create map collection from existing geo-referenced files
Create UK.qmap
Add .tdb

(the “Konsole” I ran QlandkarteGT from says “ERROR 4: `63240000.tdb’ not recognised as a supported file format.”)

I’ve even used “java -jar mkgmap.jar --tdbfile *.img” to recreate the .tdb files … same error.

Sooo, have I made wrong assumptions, used QlandkarteGT wrongly, or maybe something else?

Many thanks in advance for advice

Normally, a map contains many *.img files and exactly one *.tdb (typically osmmap.tdb). When you want to open the map in QLAndkarte, select the tdb file. Then you may be requested to select an img file - take the one which shares the name of the tdb file plus “_mdr”, i.e. typically osmmap_mdr.img.

Thanks for the response.

Yep the .zip from garmin.openstreetmap.nl contained lots of .img files - I’d had clicked quite a few bits of the UK so got :

  • one .tdb called 63240000.tdb,
  • one .mdx called 63240000.mdx,
  • one file called 63240000_mdr.img, and,
  • 73 .img files with names all matching the 6324*.img pattern (from 63241595.img up to 63243176.img (with gaps in places))

I never get past clicking the .tdb file though - QlandkarteGT barfs at that point (as I said above though, maybe I’m adding the map wrongly to QlandkarteGT?)

First: Your version of QLandkarte isn’t up to date. I assume that it works equal to the actual version 1.7…

The way to add a garmin map to QLandkarte is like Bernhard Hiller wrote: Start QLandkarte, choose “File → load map” (hope it is named so as I see german translations), choose the tdb file and then QLandkarte asks for a img file; And that should be the file 63240000_mdr.img (like Bernhard Hiller wrote).

If QLandkarte fails to open the tdb file if you opened it via the menu “file → load map”, an update of QLandkarte might be a good idea. If the actual version fails, too, then your tdb file might be broken.

On success you might not see anything because QLandkarte doesn’t zoom in it. Therefore it might be a good idea to have a gpx file to open in QLandkarte, so you can easily zoom to a region.

Splendid stuff … it was most likely the version that was tripping me up. I grabbed the latest code via SVN and built that. Version 1.7.0 does exactly what I’d hoped it would do.

Thanks to both of you for your responses!

Thanks Joachim, that was a really helpful explanation and it has worked for me too.:smiley:

After reading this topic i tried to open a map from garmin.openstreetmap.nl in QLandkarte.
But i can not find such a file like *****000_mdr.img in the unzipped folder.
Just the *****000.tdb file, a *****000.mdx file and, of course, all the *.img files.

I think Lambertus forgot to include the *000_mdr.img in his script (since he introduced the unique country ID numbers). Those files contain the search index, thanks for noticing.

With GMapTool you can split the .img file to tiles so you can use them with QlandkarteGT

QMapShack can use the .img files directly