Problems with rake db:migrate

Hallo zusammen!

We want to set up an Openstreetmaps-Server with debian-system. We have everxthing done like it is writen in the Book, installed all packages, configured mysql and on.
Everything worked fine until the command

rake db:migrate

Following error message comes up:

The full trace see below.
After that I wanted to install the composite_pimary_keys with the comman

gem install composite_primary_keys

. The following error message comes up:

The activerecord version on the system is up to date. Version 2.2.0 doesn’t exist.
Can someone help me?


Thats the full trace:

Find an older version of comoposite primary keys that support older versions of active records then? I know little about the ruby code setup. They know more on the mailinglist, but this seems like an example of hunt the right version, which is boring but necessary todo.

Thank you for your help. With version 0.9.93 it works.

But now, some steps later i have following error message.


You can skip Image Magick since it’s only needed for picture generation of traces (search for RMagick in code base).

or you try to install:

Is there a gem for Image magick available? Dunno why it fails you can try looking for those two libraries and see where they are, maybe they got moved around?

Thanks for your help so long!!

But I Don’t really know what you mean.

I tried the following things:

  1. I installed Rmagick 2.7.1 (gem instal …)
  2. I installed imagemagick with apt-get (there is no gem-installationfile)
  3. libmagick9 ist also installed.

But the error comes everytime. Perhaps you have another idea.

i found the error.

The path to the lib files was not set.

Sorry, the next problem.

I wanted to us osmosis to write the planet file into the database.

Following info comes when i start the osmosis installation:

Is that right? Is it installed now?
If yes, where do I find the osmosis command to write the planet file into the database?

I want to do this command:

osmosis --rx planet.osm.bz2 --wm host="localhost" database ="openstreetmap" user="openstreetmap" password="openstreetmap"

Can someone give me a short summary how to do this? Thank you!

bin/osmosis --rx planet.osm.bz2 --wm host="localhost" database ="openstreetmap" user="openstreetmap" password="openstreetmap"


What I ment above was that ImageMagick isn’t really needed for the basic stuff.

The command was right, There was only one space too much.

Now the osmosis program is running and aborts with this error code:

This is probably the problem… try adding validateSchemaVersion=no or ask the creator of Osmosis directly

Warning I hav eno iea wha the difference between schema versions is, you might be able to change the version with rake migrate. But that’s not within my knowledge…

Thank you for your help.
I also get the idea with the version. With

rake db:migrate VERSION=11

it works.

Now the osmosis-tool is running. I hope this was the last question from me! :wink:

Good luck…

EDIT This is not so, you need to run osmosis with -0.6 to import with api 0.6 *** EDIT* I’m not sure if you are running the mildly unstable development API (0.6) or the current one… (do a search for “changeset” which is part of 0.6)

I had the same problem and downloaded the source for osmosis and it was fixed (you will need to install JDK and ant and make sure that java is in the path before any another).
I assumed the database schema has moved up a few in the version that can be downloaded from svn but the prebuilt version of osmosis has not kept up.

Just got mine running today and is now rendering the tiles