Problem with JOSM and ways

I have earlier made segments and named each with tags for roads. Now I found that I can make Roads or Ways. Ok so long.

Now, when I make connection to this ways I need too add some nods and move them a little bit. After that I make the segments around and upload to OSM.
The OSM report Errors for node not found. Everything after that makes errors on uploading.
I have to delete my downloaded and saved part and begin again.(take a lot of time see below)
After that the ways was split up in too, with segments between.

What I do wrong ?
How do I make this too ways to one again?

Here you see.

I have also problem with that i don’t can download bigger area than now. I understand that it made problems on parts that already have lot of data but in my area I have to move and downloads so many times because every track and most of the ways are much longer than that.


Hmm, I’m not sure I understand completely, but here we go:

When making a way you should do the following (in this order):

  1. Place nodes
  2. Add segments between the nodes (showing as green lines in JOSM)
  3. Convert the segments into ways (showing as blue lines in JOSM)
  4. Select a way and add properties (like ‘highway’ and/or ‘name’ etc.)

When connecting more ways to the ones you have already created, you simply insert new nodes at the intersection and follow nr 2, 3 and 4 again.

Now, just another thing about ‘ways’: A way is a group of segments that has no branches. So if a long way has a (short) branch leading away from the main way then it has to be split and made as a new way (but with the same properties perhaps). This is important. A single way may swirl like a snake, but cannot be forked like the tongue of a snake.

I don’t know why JOSM reports errors when you try to upload. That shouldn’t happen, even when you haven’t mapped ‘correctly’. It might be caused by some problems with the database or with JOSM or something else. Sometimes the problems can be solved by saving the current JOSM map to a local file and reload it. Then try uploading again. If the problems persist, please post a detailed description here, with way ID’s and exact error codes.

Another option is to download the latest JOSM (josm-latest.jar). This verion also has tools that can join two ways into one and much more nice things.

The webserver (API) that allows you to download data from the OSM database has a limit on the size of the area that you try to download. This area is 0.3 by 0.3 degrees, any larger will result in an error.

To see your contributions to the OSM map quickly you can visit Zoom in to level 12 on the area that you’ve been working. Now left-click on the map to request that area to be rendered again. You can then see your results in about 5 minutes to about 1 hour (so check back to that area some time later).

I do exactly that.

Yes and I think that if I adjust the node the problems appear.

I don’t do that now but thanks for informations.

No it doesn’t works. The problem i still there, I have to begin again with new downloading. If I keep the old it doesn’t update nodes and ways.
But I should try again :slight_smile:

Downloaded 2007-04-01. It is old ?

Yes and it make some problems because my area don’t have so many roads and I need much bigger area at the beginning. A track is normally about 40 – 100 km

I see the problem directly in the on-line-editor. The Ways are broken in too parts.
I just zoom into that place and it don’t look good.

If I have a suggestion of the problem.
When the JOSM upload my movement of the new inserted point in the old tracks, it gives some referents too a moved point that the OSM don’t can found. What’s more that happening after that I don’t now.

If I download the area again the JOSM report uncompleted ways.

If you download in the on-line-editor.

You see a green part of Rv62 just north the cross.
It have the same name just because I from the beginning named all segments that name.
(my fault because I don’t now better )

I now think I know what kind of problem you have when uploading the changes made in JOSM. You get an ‘404’ error. I have just had the same problem. In the mailing list someone else also had this problem: the solution is to delete that way/segment/node which causes the problems. This link describes how you can do that.

Hope it helps :slight_smile:

The problem that you have with the size limit of the API is something that you can work around by downloading the area, that you are interested in, in several small portions.

Yes. Thanks I’ve got an ‘404’ error. I have found out how I can get around it.
-Make a new point on a segment
-Move the point
No error :slight_smile:

I have also found some of the function to join waysÂ……

IÂ’m still little disappointed about that I donÂ’t can download bigger area. And I also know your problem with your area that already have loot of data.

WhatÂ’s happening?
I got a ‘404’ error and my local copy is not equal to OSM.
If I download that area, my JOSM donÂ’t update the point.

Ok I have to download all again. At least 150 km * 250 km, mostly empty places.
I have to download about 5 to 10 times. I take what I need just for the time. Every download stops and wait, takes about 5 - 15 min. So I have to work over 1 hour before I can start again.
That time I donÂ’t have.
(Then if I have made new tracks, about 50 – 100 segment. Last time takes me 1 hour to upload, and I have 8/2 Mbit)

I know that OSM have to limit the downloads, but in my part of the world it drive me crazy :slight_smile:

Ah well, the OSM servers are prone to be slow, but I can assure you that much is being tried and talked about to fix that. I don’t know when these annoyances are over, so you’ll have to be patient.

For the time being you can also try another trick: I heard that some people run several JOSM instances at the same time, all of them downloading different parts of a large area. When everything is downloaded they load all the partial .osm files into a single JOSM so then the entire area is complete. Uploading can work the same way: Save your work locally → run a separate instance of JOSM to upload the changes and continue to work on the current one.