Problem introducing the map to android app

Hello, im new to programming and im developing an android app for a school project that consists on me creating some waypoints on certain spots, and give the user the choice to select one of them, and then mark the route.
I first though on using Google Maps, but after some quick searches around I found out that i couldn’t use it because it have some kind of limit on the amount of waypoints that we can use without paying for license, so I decided to use OpenStreetMap.
I found a basic tutorial on the internet teaching how to introduce the map, create waypoints and create the route, and after following that tutorial the program wasn’t working like it should. The app was opening and showing the waypoints, but the map wasn’t loading itself.
I’m programming with Java on Android Studio, using the virtual device system from android studio to run it, but also tried with my own phone, and had the same result.
The console was showing “W/OsmDroid: Problem downloading MapTile: /15/12611/17026 HTTP response: Too Many Requests” while the app was running and i tried to move the map.

I would appreciate some help :slight_smile:
Thank you

Perhaps you have downloaded a lot of tiles already? As says: “OpenStreetMap data is free for everyone to use. Our tile servers are not”.

I’m assuming, of course, that you’re trying to use OpenStreetMap’s “standard” tiles - the ones that you see at at Try using a different tile server to see if that message goes away. Have a look at to see if anything there helps you. If you want to create your own tiles, have a look at

If you’re thinking “hang on - I’m just using OsmDroid - I haven’t said anything about which tile servers to use” have a look at - that is a really simple OsmDroid example that uses a different tile source.