Potlatch P2 unable to mousewheel zoom, crashes, with Firefox 54

I’m having trouble with Potlatch now I’ve been upgraded to Firefox 54

First thing I noticed was that the mouse wheel zooming was not working, the +/- zoom buttons (top left corner, never noticed them before!) work fine.

But even worse, it’s crashing the Adobe/Shockwave Flash plugin so that no reliable editing is possible. To crash it, just click anywhere away from an object!

Anyone else seeing this?

I’m running on Linux Mint 17.3 (Ubuntu 14.x derived OS), Flash plugin is (but I retried 25.0 which worked fine before and it’s the same), Firefox 54 (64 bit).


I can confirm both issues, mouse wheel is not working and it is reliably crashing when clicking anywhere on the background. Firefox 54.0 on Ubuntu 16.10, 64bit.

On Chrome, everything seems to work ok, so this might be Firefox specific.

Can you open an issue on trac? https://trac.openstreetmap.org/newticket?component=potlatch2

Me, using ubuntu 16.04, also have crash on adobe flash sites, like this official government site → https://ccff02.minfin.fgov.be/cadgisweb/?local=nl_BE
Also, my middle mouse wheel not working on that site. Before… it worked.
my opinion ; its a firefox “thing”, or a adobe flash “thing” … :roll_eyes:
i mailed it on Firefox forum → http://forums.mozillazine.org/viewtopic.php?f=9&t=3031146

EDIT : i dont use potlatch, i use JOSM .

Works for me in Firefox 54.0 on Windows 7. “about:plugins” shows “Shockwave Flash 26.0 r0”

I also have that version of SWF :wink:

OK, i installed Firefox ESR next to my ‘other’ firefox, and i see that this ESR firefox has a ‘Next Generation Java Plug-in 11.131.2 for Mozilla browsers’ included.
I tested it on https://ccff02.minfin.fgov.be/cadgisweb/?local=nl_BE , and… all worked … my middle mouse wheel also :smiley:
And so far… (knock on wood :stuck_out_tongue: ) … no crash or hang … :wink:

Follow up is here: https://trac.openstreetmap.org/ticket/5457

Thanks @Cebderby

Not sure why a Java Plugin should be relevant for Flash. Seems like you’re jumping to conclusions here.

Maybe a “combination” ubuntu unity / flash / firefox thing ? I tested firefox nightly, and had troubles with unity-gtk-module →

i mailed a bug-report at ubuntu → https://bugs.launchpad.net/ubuntu/+source/unity-gtk-module/+bug/1309344

Since the future of unity for ubuntu is becoming to an end → https://fossbytes.com/ubuntu-17-10-daily-build-gnome-default/

Is here somebody who has ubuntu gnome to test above problems ?

Cebderby has done some great detective work at https://bugzilla.mozilla.org/show_bug.cgi?id=1374559 - currently seems to be waiting on a Firefox dev to help, but it looks 100% like a Firefox issue rather than anything else.

Gonna be ‘a long wait’ :frowning:

In unrelated news: https://blogs.adobe.com/conversations/2017/07/adobe-flash-update.html

RIP Flash.

GOOD RIDDANCE TO BAD RUBBISH ! :sunglasses: :stuck_out_tongue:

I was waiting too long for this.

RIP Flash Player. But Adobe AIR lives on.

It’ll be good for OSM to finally have a decent desktop editor. :wink: