Please remove Referer check

Because I can’t post a message on forum when in Firefox’s about:config network.http.referer.trimmingPolicy is 2 and network.http.referer.spoofSource is true. Setting them in that way improves privacy.

did you try to use the newer network.http.referer.XOriginPolicy? works for me and is actually the correct solution (dont know why they didnt invent this long before)