Please help... edited info not being displayed on Map

Hello… I’d really appreciate your help, please.
I tried editing a node, in order to update the business info. I was able to see the saved changes while in Edit Mode. However after exiting, the changes were not visible on the map … and the old display info remained but is now partially hidden.
I tried updating the node again, moving it around and saving the edits but nothing changed.
Finally I deleted the node, and still the partially hidden name remained when I exited Edit Mode and was just viewing the map.
I thought creating a brand new node in the same area might work. So I did that but still can only see the saved info in Edit Mode. Plus the old name remains partially hidden while viewing the map.
Anyone knows what I can do to fix this situation and get the edited info. to show?
Thanks for any help!

If you’re asking about , it displays OK for me. If it doesn’t for you you might just have to wait a bit. Different places around the world use different tile servers.

I wonder whether the building in which the pharmacy is located has the correct type. Commercial buildings are for offices, not for shops. For shops use retail

The same holds for the landuse, retail for shops, commercial for offices.

BTW, the label of the pharmacy appears a bit strange for me at zoom level 19.

Hey guys, thanks for the help.

Yes, that’s definitely the node I am asking about. Using your link I was actually able to see that the label for the new node is there, but the label for the old node is still displaying as described before. Only now it is partially hidden under both the building and the new label.

I am unable to the see the new node/label on my map when logged in, but that is probably because of the differences in the tile servers like you said.

I am positive that what you are seeing (label looking strange at zoom level 19) is what I am seeing and trying to describe and resolve.

The label for the pharmacy looks strange because there is a partially hidden (old) label under the building and now the new label is positioned just above the words of the old label that are visible. So there is sort of an overlap of two labels in the same space.

To verify what I am describing, if you compare what the label/name for the active node should say, with what is showing at zoom level 19 you would see that what is being displayed is not accurate. Please tell me that this is what you are seeing?

PS: I changed the building type to retail as suggested but it did not help with the issue at hand.

Any suggestions now that we are a little closer to resolving?


I don’t think this is a problem with the data. You can change the view to the Humanitarian Layer (layer chooser RHS) and the pharmacy shows cleanly.

I think, but cannot be sure, that what has happened is that it just happens to lie on a ‘tile boundary’. The map is made of millions of small tiles, and when a change is made the data local to the change is used to update the tiles which make up the map. The tiles refresh independently, so I think the vestiges of the older pharmacy are just because that tile has not been refreshed yet. Rendering artefacts are not uncommon when the map is first refreshed, which is why looking at the Humanitarian Layer is often a good sense check, because this uses the same data but different rules, running of different hardware.

Hello SK53

I do see the label cleanly in the Humanitarian Layer, unfortunately I did not know this could be used to verify changes or make quick checks in this way.

The bonus is that I am now also seeing the both labels in the Standard Layer, when I was unable to just a couple of hours ago. Maybe that’s a sign things are “refreshing” though slowly on my end.

Fingers crossed I’ll see a clean label in Standard view within a few days. If not I’ll reach out with an update.

As a side note/FYI, when I made the initial changes to the old node I waited over 2 weeks to see if the old label, partially hidden would go away and for the new label to show (again I did know about using the Humanitarian Layer) but neither happened. This prompted the other actions described in my first post.

Nonetheless thanks for your help, you put my mind at ease and gave me some hope.

This is what I see

I’ve looked for other objects that could cause this, but haven’t found any.

It’s definitely a tile boundary issue:

The lower tile will get updated at some point - I’m guessing that the delay is because the “standard” tile servers are very busy at the moment.

Hi Escada…that’s what I see as well and thanks for making some additional checks.

SomeoneElse thanks for putting my mind at ease with your feedback. I’m happy to have something to work with and to be patient while the servers do their work.

I will give it some time and provide an update if I don’t see any changes within 2 weeks.

I’ve just done which normally has no effect (because the tile server is too busy) but just now seems to have worked.

Hi SomeoneElse

Thanks for trying to speed up the process by trying things, even those on the long shot.

You mentioned that it seems to have worked for you, so I logged in and checked my map. I got in, refreshed, switched to Humanitarian Layer and back to Standard, zoomed in and out, refreshed again… Unfortunately I am not seeing any changes; the tile boundaries are still “merged” and the label is still showing as it has been.

Maybe a little more time is needed?

You’ll be using a different tile server for us in Europe I suspect.

Probably… I guess more patience and time is needed, so I’ll monitor and wait. In 2 weeks I’ll advise if I don’t see any difference and inquire about what my next steps should be. Thanks a lot

It is possible that one of the tiles will not be refreshed without marking it as dirty like SomeoneElse did. This is possible when the algorithm does not realise the content of the tile has to be refreshed, maybe this is the case here, as the actual point that has changed is in the top tile, the bottom tile might not know that it has to be re-rendered.

I’m not familiar with those kinds of details of the algorithm, so I can be totally wrong.

Hello everyone

The label is now showing cleanly in both the Humanitarian and Standard Layers.

The changes happened sometime over the last 3 days; I am thrilled that all seems well now.

Thank you for your kindness and contributions.