Osmxapi download fails

Is there a problem with osmxapi or do I input the wrong command, check this:

C:\build\OSM>wget http://osmxapi.hypercube.telascience.org:80/api/0.5/way[bbox=53.42,24,57,16.25] -O test.osm
–21:52:10-- http://osmxapi.hypercube.telascience.org:80/api/0.5/way%5Bbbox=53.42,24,57,16.25%5D
=> `test.osm’
Connecting to osmxapi.hypercube.telascience.org:80… connected!
HTTP request sent, awaiting response… 200 OK
Length: unspecified [html/xml]

0K ->

21:52:42 (1.23 B/s) - `test.osm’ saved [38]


<?xml version='1.0' standalone='no'?>

So not much being fetched, sometimes I get the full header, but still no data.
Does the same command work for someone else? Same problem with this command:

wget -O uae.osm “http://osmxapi.hypercube.telascience.org:80/api/0.5/*[bbox=53.42,24,57,16.25]

All using the commandline in windows vista

There appears to be a server error. After 26s the server disconnects with a HTTP 501 message. See also my ‘curl’ trace below. I wonder how to get into contact with server administrator…?

------ 8< ------

curl -v -g http://osmxapi.hypercube.telascience.org/api/0.5/*[bbox=8.6133,49.3826,8.7008,49.4396] -o test.osm

GET /api/0.5/*[bbox=8.6133,49.3826,8.7008,49.4396] HTTP/1.1
User-Agent: curl/7.16.3 (powerpc-apple-darwin9.0) libcurl/7.16.3 OpenSSL/0.9.7l zlib/1.2.3
Host: osmxapi.hypercube.telascience.org
Accept: /

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:–:-- 0:00:26 --:–:-- 0< HTTP/1.1 501 Internal Server Error
< Date: Sat, 12 Jul 2008 08:07:45 GMT
< Server: Apache/2.2.3 (Debian) DAV/2 SVN/1.4.2 mod_python/3.2.10 Python/2.4.4 PHP/5.2.0-8+etch11
< Content-Length: 0
< Connection: close
< Content-Type: text/html; charset=UTF-8
0 0 0 0 0 0 0 0 --:–:-- 0:00:26 --:–:-- 0* Closing connection #0

I believe the server admin is crschmidt and he hangs around in the talk IRC channel most of the times.

Still doesn’t seem to work, very annoying. Ended up making a perl script that fetches over 800 submaps via the OSM api and merges them using osmosis to cover the area I’m interested in. Anyone else having any luck using osmxapi?

Command used is:
wget -O uae.osm http://osmxapi.hypercube.telascience.org:80/api/0.5/*[bbox=53.42,24,57,26.25]

Still not working here, keep getting 501 errors. I’ve tried reducing the bounding box significantly, but it doesn’t seem to make any difference.

I am also getting 501 errors after the waiting period, using Composer and different xapi-addresses. api gives me 403 errors after downloading some submaps so this doesn’t work either?

Has anybody figured out what the problem is? The last post in this thread is some months old.

Basically: shit happens sometimes, it doesn’t always work. The garmin tools should use planet.osm instead.

answered in your other thread.