OSMmap on Mapsource problem, cpreview

I tried today to install osmdata changed by mkgmap, to install in mapsource with Mapsettoolkit v1.77
Link to Free cGPSmappper with 0100d version, later tried it with the Personal cGPSmapper version0100d evaluation.

The last line in cGPSmapper\cpreview.exe is.

Indexing IMG files which are using 6bit label coding mau result in NON working index.

after a while
Mapsettoolkit timebox (not responding)
and then a popup :

cpreview does not work anymore.
There is a problem…program is closed.
button: program closing
hit the button then cGPSmapper mapsettoolkit maked it to the end.

But map not good installed.

I have tried both ways to install cGPSmapper, in the installation menu.

Somebody has a answer?

Searched the internet to find a solution, did not find a hint.

PC, Windows 7 64 bit.

The same set was installed by someone else no problem.

You can’t use any cgpsmapper functions like cpreview with mkgmap compiled IMG files. cgpsmapper and mkgmap IMG files are not compatible. You need to run mkgmap with the TDB option. Once you have generated the TDB and overviewmap.IMG files using mkgmap you can INSTALL them using MapSetToolKit.

The set produced by someone else contents: mapset, mapset.tdb, mapset.mdx, mapset_mdr

You should use osm2mp if you like cgpsmapper :slight_smile:

If you have all the required components you should be able to use MapSetToolKit to INSTALL the mapset. Click the INSTALL button on the bottom right of the opening screen. Then add the TDB, overview map, mapset directory, and registry name in the popup and click INSTALL on the popup.

Re. osm2mp. It gives a direct translation of OSM data into MP. With a large map maintaining routablility is difficult with osm2mp because it converts routing errors, like self connecting loops, into MP format. These then have to be removed manually in an MP editor. mkgmap automatically fixes these errors during compilation, so none of the manual error correction is needed.

No, osm2mp automatically fixes self connecting loops

Good to know. I must have been doing something wrong.

Hi, I am new to this great site on OSM.

I downloaded the New Zealand osm_routable_tiles and tried to install into mapsource using Mapset Tool Kit V.177, but encountered a series of warnings in cgpsmapper that says:

Element spans more than 10 degrees!
Error E017: cannot parse coordinates

I tried another set on Australia and gets the same. Wondering what did I do wrong?

I didn’t use the osm_routable_mapsource.exe because it won’t allow both sets to be installed concurrently in mapsource.

Thanks much for helps!

My problem is solved, i wrote a .reg in wordpad. for windows 7 PC, saved as name.reg in wordpad
put the files and the *.reg in C:\Garmin\Maps\
and then hit the .reg file

it was nicely put it in the register and in mapsource.
also the routing was fine.
but no uninstall, but that problem is solve in mapsettoolkit unsinstall the file, this is only in the register, the files in C:\Garmin\Maps\ you have to uninstall by hand.

later on i received a .exe with the unsinstall file for the register, her you can also use mapsettoolkit to uninstall.
also for changing the *.typ file.

so no need to install with mapsettoolkit and cgsmapper, i believe this combo doen not place route files correctly.

See my first note, this thread. cgpsmapper doesn’t work unless you use OSM2MP.