OSMapTuner – Bug Report

Hi OSM-Community!

Do you experience a problem with the OSMapTuner?

Please report here your bugs!

Thank you,
the OSMapTuner team

When GPS is not activated the “jump to current position” gives an corresponding message. But the current position is shown correctly on the map anyway. As an user I would expect to go to the current position anyway. Typcially this would be better than using the last position.

But I wonder if this behaviour is a feature or a bug.

I try to open OSMapTuner while the SD-Card of my mobile phone is connected to the PC → Crash.

I can not install this application from Google Play:

This app is incompatible with your Velcom Samsung GT-S5660.
This item cannot be installed in your device’s country.

This behaviour is more a feature than a bug. We will consider changing it for the next version.

Thank you for the report. We will fix it in the next version.

This should work now. Please try to install it again and reply, if it doesn’t work.

best regards,

Since few days OSMapTuner doesn’t get the map from zoomlevel 18+ rendered. The progress circle is turning but after it has disappeared just a blank map is shown. That did not happen with my Sony Ericsson Xperia Mini pro at the beginning. I couldn’t tell that I did something odd in the meantime and it looks like having stopped functioning unexpectedly.

A reinstall didn’t solve the problem.


OSMapTuner will not work from April 1st to April 4th due to the scheduled service. Although it is claimed on the main page, that the database is in read-only mode, further research reveals (http://blog.osmfoundation.org/2012/03/27/service-schedule-march-april-2012/comment-page-1/), that

This means, that it is not possible to request data (it is also not possible to activate the “data” layer on openstreetmap.org), and therefore the vector rendering from zoomlevels +18 does not work (unless you have saved data).

best regards

I have Ainol Novo7 Paladin tablet which doesn’t have hardware GPS. So for this device osmaptuner doesn’t show up in the google’s play store. But it works great afrer I downloaded and installed apk file from the web page.
When osmaptuner tries to determine my current location it quickly gets coarse location based on wifi and draws correct map in background. Then it apparently starts waiting for more precise location so I just press “cancel” and can start editing tags.
So it is absolutely usable on devices withot hardware GPS but it would be much more convenient to download it directly from Play store.

Thank you for the hint. You cannot see the app on google play because we request the permission ACCESS_FINE_LOCATION which implicitly asks for hardware GPS. You are right, the app works properly without GPS and we will define it as optional feature for the next version.

best regards

You should update credits that say “version 0.9” instead of “version 1.0” :wink:

I tried to use your app for addr:housenumber updating but I encountered one huge bug and several inconveniences.

I did one round in my neighborhood and entered around 40 housenumbers, but when I have finally send data to server there were only maybe 5! house numbers updated and in some random fashion that I could not resolve why this numbers. They were not consecutive.

Also I did have problem with starting my location update. I have forgotten to start GPS and your app tried and tried to find my location and finally I needed to stop process to start again location update. There should be way to stop location update, and it could be nice feature to be able to choose wifi over gps location update.

It would be nice to have addr:housenumber textbox first in a list of building’s properties and if it is empty to start editing. Also to set default keyboard for this textbox to numeric (with ability to change to alphanumeric). Most house numbers are pure numbers and when I need to enter number on small keyboard I need to hold long on some letter for number to appear. You should exclude auto suggestion for addr:housenumber because it isn’t helpful there. It would be nice to be able to set to mode where app would not render again map when I return from editing properties because usually we don’t care for data that we entered than that were not entered.

Interesting app, but currently I prefer map print and ‘pencil’ tool, but I hope to be able to use you app someday.

@sijanac: I think that is correct to render again the map after an editing because I can see if the software has accepted my changes.

Sometime when I click the “upload button”, the software open an editing window for the object that is below the upload button: I need to try with a capacitive pen to understand the problem. Maybe is only my finger that is not precise. My device is a Galaxy W.
Another interesting feature could be to have a list of “personal required” tags for each object. For example I can choose that each way should have at least the max_speed tag: all ways without this tag should be rendered with the orange color (now seems that only some ways are good without max_speed). This can be useful when I need to add specific tags to objects: it’s more intuitive.

I know it sounds stupid, but are you definitly sure, that you really clicked “Save”, when you left the house object for editing? The only other thing I can think of would be a database problem (maybe because of the sd card?).

What device, Android version do you have? There is “Cancel” button for the location update dialog, but I know of one device that strangely decides to not show it. So I guess you have the same.
The feature to choose between network and gps positioning sound interesting for the next version.

Your suggestion about setting the default keyboard for housenumber to numeric (but changeable) is nice but not easy, because keyboards are device dependent. For instance: the numeric keyboard of the HTC Desire (2.2) has a button, which allows you to change the keyboard to alphanumeric. But the numeric keyboard of the Samsung Galaxy SII (2.3.3) does not have such a button.

We already discussed this feature in the past, but decided to leave it out of the first version, because of its complexity. It will come, but I can not tell you when.

best regards,

Well, I did clicked “Save”. I wouldn’t do that kind of mistake for 35 times! I am also programmer and I did have ‘stupid’ users but I assure you that this was not problem here. Not that I am saying that I am not stupid :smiley: I looked and when I click ‘save’ it renders again and if I click ‘cancel’ it doesn’t and if you recall I it I was anoyed with this constant rendering.

But I remember something. I did try again. This checking for server data. I think that after I have entered some data in text box ‘upload’ button enabled and that I have clicked upload before it finished ‘checking’. I am not 100% that checking didn’t finished but maybe to look there for bugs?

HTC Desire, 2.2.2

“Please wait… Determining current position.”, and below is some grey line that is wide as dialog but there is no text and I doesn’t react. Now I am inside and updateing location goes and goes… After minute I killed process and it did force close. Downloading data does have ‘cancel’ button’. Color is standard android button color.

Also OK and Cancel button on properties editing dialog is too small. How about addr:housenumber to be first property for building. Then we would’n need to scroll.

I created some android apps so I know that you can start keyboard as soon as you open dialog so this would reduce need for one touch. Maybe to try textPostalAddress for input type.

I noticed that grey line (that could be same as one in upload dialog) behind this small ‘ok’ and ‘cancel’ button.


It is not possible to upload data, when it is not finished with the conflict check. The upload button should only get activated after writing a comment.
But I think, the problem was the data check. It was either a bug (or connection problem), that caused some changes to disappear, or you had some conflicts (which is quite unlikely, since somebody else had to make changes on your objects at the exact same time).

This is strange. I know of another device, where the UI is buggy with our custom button design. But I own a HTC Desire (2.2) for myself, and here the buttons are there, although quite small…
Nevertheless this buttons should be there and we will look into the UI problems for the next version.

I don’t think, that we will set addr:housenumber as the first property for buildings, because that’s a very custom wish. We sort all tags alphabetically, because this makes the most sense. If we customize the order in one object, we have to make it customizable for all objects. I also think, that there are more opinions on this topic. You want to have the housenumber as first entry, but someone else maybe wants the city first, because he likes to add the city and street name to every building he edits.
We actively decided to not show the keyboard on opening the dialog, because it doesn’t make sense on devices, that have a hardware keyboard. But I think, that we will change that, since the number of such devices is declining and we heard this wish more than once :slight_smile:

best regards

Is this topic still monitored by OSMapTuner developers?
The 0.9 version crashes on Android 4.2 (CM10.1)
on zooming in to 18 or selecting “Login” from menu.

E/AndroidRuntime(29095): FATAL EXCEPTION: main
E/AndroidRuntime(29095): java.lang.RuntimeException: Unable to resume activity {at.srfg.osmaptuner/at.srfg.osmaptuner.OSMapTunerActivity}: java.lang.RuntimeException: Buffer not large enough for pixels
E/AndroidRuntime(29095): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2866)
E/AndroidRuntime(29095): 	at android.app.ActivityThread.handleResumeActivity(ActivityThread.java:2895)
E/AndroidRuntime(29095): 	at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1286)
E/AndroidRuntime(29095): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(29095): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(29095): 	at android.app.ActivityThread.main(ActivityThread.java:5193)
E/AndroidRuntime(29095): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(29095): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime(29095): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:795)
E/AndroidRuntime(29095): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:562)
E/AndroidRuntime(29095): 	at dalvik.system.NativeStart.main(Native Method)
E/AndroidRuntime(29095): Caused by: java.lang.RuntimeException: Buffer not large enough for pixels
E/AndroidRuntime(29095): 	at android.graphics.Bitmap.copyPixelsFromBuffer(Bitmap.java:417)
E/AndroidRuntime(29095): 	at org.mapsforge.android.maps.mapgenerator.FileSystemTileCache.get(FileSystemTileCache.java:266)
E/AndroidRuntime(29095): 	at org.mapsforge.android.maps.MapView.redrawTiles(MapView.java:392)
E/AndroidRuntime(29095): 	at org.mapsforge.android.maps.MapView.setCenterAndZoom(MapView.java:798)
E/AndroidRuntime(29095): 	at org.mapsforge.android.maps.MapView.setCenter(MapView.java:438)
E/AndroidRuntime(29095): 	at org.mapsforge.android.maps.MapController.setCenter(MapController.java:57)
E/AndroidRuntime(29095): 	at at.srfg.osmaptuner.map.MapFragment.initMapForZoomLevel(MapFragment.java:787)
E/AndroidRuntime(29095): 	at at.srfg.osmaptuner.map.MapFragment.onResume(MapFragment.java:584)
E/AndroidRuntime(29095): 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:782)
E/AndroidRuntime(29095): 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:933)
E/AndroidRuntime(29095): 	at android.support.v4.app.FragmentManagerImpl.moveToState(FragmentManager.java:916)
E/AndroidRuntime(29095): 	at android.support.v4.app.FragmentManagerImpl.dispatchResume(FragmentManager.java:1592)
E/AndroidRuntime(29095): 	at android.support.v4.app.FragmentActivity.onPostResume(FragmentActivity.java:393)
E/AndroidRuntime(29095): 	at android.app.Activity.performResume(Activity.java:5195)
E/AndroidRuntime(29095): 	at android.app.ActivityThread.performResumeActivity(ActivityThread.java:2856)
E/AndroidRuntime(29095): 	... 10 more
W/ActivityManager( 2250):   Force finishing activity at.srfg.osmaptuner/.OSMapTunerActivity