osm2world : parameter drawBuildingWindows has no effect ?


In the configuration file standard.properties, I’ve try to change the property **drawBuildingWindows **from **true **to false.

But I didn’t see any change when I relauch the application. Windows are always displayed. Does this parameter works anymore ?

Or can I disable this feature for a particular building ?

Thank you !

You have to wait a couple of days before you see the change.

This setting was indeed replaced in more recent versions of OSM2World. Now there is implicitWindowImplementation, which takes one of the following values:

NONE - no windows at all
FLAT_TEXTURES - a repeating texture image on a flat wall
INSET_TEXTURES - windows using a combination of geometry and textures
FULL_GEOMETRY - windows with actual geometry

There’s also a second option, explicitWindowImplementation, which takes the same values and controls buildings for which the OSM database contains the location of individual windows.

Buildings or building parts tagged with window=no will not have windows in OSM2World. Obviously, please only add that tag for buildings that really have no windows (or locally in your own copy of the data).

The question seems to be about running your own instance of OSM2World, not about using an existing online service. (After all, you cannot change the standard.properties configuration of someone else’s online service.) So waiting isn’t going to have any effect whatsoever.

Thanks for the explanations ! I use my own OSM2World application. I make some tests with personalized textures.

I change locally OSM files, but these elements will not be published.

For my test, “window=no” is exactly what I needed.

Thank you.