osm@pgsql reprocessing ways

I have done some homework on this and I have come across a problem I am not sure what to do with.
I run the following command.
time /usr/local/bin/osm2pgsql -r pbf -m -d gis -C 30000 --number-processes 4 --slim --flat-nodes=${HOME}/flatnodes planets/planet-latest.pbf

Everything went as planned and I got input much like the following at the end.(I can not post the results as I went and out put it to the screen and it is too long for my direct terminal screen.
The time it took was roughly 4 days and the total node, ways and relations was close to:

Number of nodes 3516374063
Number of ways 366520113
Number of relations 4468562

it processed the nodes at a rate of 1694k/s, ways 5.66k/s and relations 20/s.

However after getting the much the same results as below. It is now showing

processing ways (number of ways) 0.54k/s.

Why on earth is it re-processing the ways and why is it so slow.

The database is showing all of the tables as such:

          List of relations

Schema | Name | Type | Owner
public | geography_columns | view | postgres
public | geometry_columns | view | postgres
public | planet_osm_line | table | postgres
public | planet_osm_nodes | table | postgres
public | planet_osm_point | table | postgres
public | planet_osm_polygon | table | postgres
public | planet_osm_rels | table | postgres
public | planet_osm_roads | table | postgres
public | planet_osm_ways | table | postgres
public | raster_columns | view | postgres
public | raster_overviews | view | postgres
public | spatial_ref_sys | table | postgres

To me it looks like all the tables are there. At .53k/s it is going to take my server 7.2 days to do this, not to mention if it choses to go over the relations again.
Should it be doing this.
What did I do wrong.
Also does anyone know how to get the output to go to a file, if I remember correctly a pipe in bash does not work correctly. Next time I run this command, I would like to be able to log the results from remote ssh, so I know what all happend.
If you have any question or need more information I more then willing to provide it as long as I have access to it.
Thank you,


Processing: Node(1507455k 311.7k/s) Way(141480k 38.61k/s) Relation(1469760 74.91/s) parse time: 28120s
Node stats: total(1507455627), max(1812375450) in 4836s
Way stats: total(141480878), max(170086664) in 3664s
Relation stats: total(1469765), max(2263585) in 19620s

Pending ways took 6071s at a rate of 13397.84/s
Pending relations took 1s at a rate of 0.00/s

All indexes on planet_osm_roads created in 682s
All indexes on planet_osm_point created in 1340s
All indexes on planet_osm_line created in 3723s
All indexes on planet_osm_polygon created in 4274s
Stopped table: planet_osm_ways in 23804s

Osm2pgsql took 57999s overall (16.1 hours)

real 966m38.279s
user 324m38.769s
sys 45m51.064s

Is it perchance saying something like “Going over pending ways. NUMBER ways are pending.” right before processing ways again? That is perfectly normal. Some ways and relations cannot be fully processed in the first iteration, so it goes over them again later.

Also, on a machine without SSDs, a whole week for a full planet import is nothing out of the ordinary.