OS Streetview not working in JOSM

Hello all,

For some unknown reason OS Streetview is not displaying anything in JOSM when I select it as an imagery layer. Literally noting comes up - there is a blank white background - when I select it. It has always worked before and all other layers work as normal. It worked a few weeks ago and has not worked, so far as I can tell, for the last few days. I updated to the latest version of JOSM to no avail. Anyone know what the problem is?

Cheers, Will

Its a problem with the server that the OS Streetview tiles are stored on. It has been down for a couple of weeks.
See this thread from the mailing list: https://lists.openstreetmap.org/pipermail/talk/2014-July/070135.html
Also platform status here, it lists the imagery server (faffy): http://wiki.openstreetmap.org/wiki/Platform_Status

You can set JOSM to use the temporary server that Grant mentions in that message. In JOSM, go to Imagery menu, then Imagery Preferences. Then add another entry for OS Streetview, with the imagery URL:


It looks like the server is now working again. So OS Streetview should work in JOSM as usual.