orthogonalize with JOSM

I tried mapping a few buildings having surveyed them manually. When entering them into JOSM, they are clearly rectangular but in the mapnik rendering, they come out slightly diamond shaped. I used the orthoganalize tool and even going back and rotating them to point due North, they are clearly rectangular in JOSM. Any idea what’s going on and how to avoid this.

Is this perhaps due to the map projection used by mapnik? I would have thought that as you get further from the equator, the scale would get gradually larger but the shape of objects would be preserved: the X scale and Y scale would remain the same.

You can see the buildings in question here:



Change the Projection in JOSM. It’s predefined as some kind of WGS-projection. You have to switch to MerKartor!
Settings → 3rd tab from the top.

Also check your version of JOSM, this has been the default for ages!

Hmmm - I have one of the very recent versions of JOSM and like the OP, it was set to WGS. I did wonder why my roundabouts were appearing as ellipses…

I know that setting it to Mercator works (verified by matching the aerial), but I don’t understand why. Wouldn’t you want to use an equal-area projection to make roundabouts circular?