I downloaded a map from from “” a “Routable Bicycle (Openfietsmap Lite)” from US-Florida.
I install this map.

I downloaded my own map from via Overpass API. I use the 20010.typ file to compile it, but when I load both maps in Basecamp, they look different.

self made map

I tried the a self made map with the 22975.typ file, but there was not change.

I have a second difference. When I zoom my outline map become white. The still works:

self made map

Many greetings

How did you compile your map (mkgmap default settings?) The Openfietsmap lite uses its own style defintions, the typ file cannot be used with the default map. The settings for the overview Basemap are in the info file. Without this file there is no basemap.

# Style options.

# The levels specification for this style

#levels = 0:24, 1:22, 2:20, 3:18, 4:16

levels = 0:24, 1:22, 2:20, 3:18
overview-levels = 4:17, 5:15, 6:14

I had problems using the Styles-Light so took Styles!
Upps! That is not the same !!!

I copied the Style directory from
I use osm_bnl.args and the type file 20010.typ.

my command after splitter is:

I modified (bold) them a little:

My ./Styles/options is the same as yours:

My ./Styles/info file:

Ah, well, the typ files for the lite and full versions are the same. So don’t worry. Only the lite will render less objects like buildings.
So its ok to use the full version with that typ file. I meant option file, not the info file, sorry.
Which map are you using in Basecamp? The gmapsupp does not have an overview map, maybe thats the reason?

Here some more Information:

I have two maps in basecamp, both from this morning. The Lite installed by the exe file.
I installed the gmapsupp by GMapTool into my c:\garmin\maps\US-Florida directory.

My US-Florida Dir:

The Dir:

Using my US-Florida map:

Using the map



The gmapsupp.img does not contain an Overview map. When you run mkgmap this overview map is only created for the pc version.
Mkgmap will write temporarily ovm_*.img files to create such map. Your mapset.img is empty because the ovm files are not written into the gmapsupp.img. If you have compiled those files, you can install the mapset with mapsettoolkit or run the nsi script with nsis.

Martin, I have split your question off from the long garmin thread into a new topic.

Is there a difference between the java-file running under Linux or under Windows?

I make the download of the osm data, splitter of files and run MKgmap on my Linux maschine. Then I start my virtualbox with win10 and use a share dir to access to gmagsupp.img file. I use GMapTool to create a new map directory with the new map in. Then I change to this directory and install the new map.

How to get this ovm_*.img into the map?

In my working directory ovm_*.img are created:

I’m not familiar with Linux. Maybe someone else has an answer or you can join the mkgmap-dev mailing list to ask questions:

How to get this ovm_*.img into the map?
You dont have to. Mkgmap will write it into the overview img (20010000.img)
All you need to do is install those index map files on your computer. For Windows I use nsis (you need add nsis as option in your args file).
Or else you can use mapsettoolkit. But I dont know how to do that on Linux.

I modified (bold) my mkgmap commandline :

Then I became a new additionally map osmmap.img. I use these map und gmapsupp.img to build the map for basecamp and it works!

And it looks nicer, than the view from Have a look at the small overview-map. Here are no details only larger blocks.

When I add the osmmap.img to build the new basecamp map it replaced my name by OpenFietsMap(US); This is the family-name: from osm_bnl.args.

I think one problem is solved. :slight_smile: The overview map.

But now the light green (light green → hex: d8f7ba) color of map. :confused: The contrast on my garmin oregon 450 is not so good, I would prefer the white color from the

Great that you solved it :slight_smile: The rough pattern in the light style is used to make it render faster.
The background is natural=background
In your polygon file this is specified with natural=background [0x010100 resolution 12]
The light style that you prefer is using natural=background [0x010200 resolution 12]
Another option is to edit the polygon 0x010100 in the typ file with typviewer, so you can choose another color.

In the directory ./Styles I have a file polygons
here is only one position with natural=background

When I change this to 0x010200; nothing change in basecamp!

But it is okay! I leave it as it is! I am happy now!
I want to download and test my modification, I made in as soon as possible in basecamp. I am driving with my bike and my garmin and I am looking for the bicycle ways. When it is running under bascamp that is okay. I can download your map later …

Thanks a lot :sunglasses:

Probably Basecamp still sees the old map in the memory cache. Refresh the tiles with 2x ctrl-G.

I am testing…
with Styles-light
with Styles
and with new color number

Answer tomorrow…


That was a very good info :slight_smile:

What I did:

I copied 20010.typ to 20011.typ and 20013.typ, that I have no conflict im Basecamp.

I made 3 different Styles directories
./Styles → copy from
./Styles-light → copy from
./Styles10200-> copy from ./Styles

in ./Styles10200 I changed in the file polygons the field natural=background [0x010200 resolution 12]

I use 3 different command lines for:
mkgmap -c template.args --gmapsupp --tdbfile --overview-mapname=osmmap 6324*.osm.pbf -c osm_???.args 200xx.typ

Your map (

My osm_styles-light

My osm_styles

My osm_styles new background color


In all my maps there all same light grey fine lines, but not in yours! You can see some in the upper pictures too.
(Blue mark)
The red mark where the water area have differnet sizes, could be arise by the lower resolution from the lite version!

My ./Styles maps

Your US-Lite map

I have no idea what those grey lines are. Did you check the raw OSM data?

How to check raw data?

What is with the water in “My osm_styles-light” map?

With an OSM editor in the database of course.
I dont know what exactly caused the water shape difference.
Edit: maybe this option?

polygon-size-limits=17:2, 15:0