One way routing error?


I’ve stumbled upon a strange routing problem while driving around Spain using OsmAnd and Openstreetmap data. Have been tweaking the situation, but still get very strange routing solutions.
To see the problem, enter starting point “Pos@: 2.868107 42.231277” and endpoint “Pos@: 2.874780 42.230594” in The suggested route blatantly ignores the one-way attribute of the exit ramp (it tries to reach the trunk road via the exit ramp). The legal and only viable route is via the tunnel.

Did I make mistakes in the osm data, or is the router buggy for this kind of situations?

Another problem I encountered is here: From: “Pos@: 3.059944 42.143451” to “Pos@: 3.067326 42.137214” should be routed over the roundabout, but suggests an illegal left-turn over a non-existing junction (there is no road connecting the suggested path?).

when browsing to, be aware about the upper right corner: The routing database is from 29.10.2012 !!

so any modification in raw OSM data since then is not computed there.

Try for more recent engines.

Also tell us from what date your offline Osmand map file is from.

Boy, do I feel stupid now… thx for the heads-up. I was fooled by the extremely accurate map view, never noticed the routing database date (and didn’t realise there was any difference!). That explains all. I tried and it’s spot on! The OsmAnd data was from before my early edits, that’s what started my further investigation and edits.
The roundabout problem is also solved!