Not Routable

Hi Guys,

Noob here on this forum !!

I have downloaded the Germany Routable map yesterday (from Garmin.OSM) and placed it on a Removable Drive and Basecamp sees the Map and it’s active.

Now when I recalculate between 2 Points, it doesn’t go via street, but it’s a DIRECT line. Activity Profile has been set to Car, but I have tried it with others as well.

Start Point is this: N53.26050° E7.26878°
End is this : N52.54900° E13.38333°
(No other Points in between and both points are in the Map.)

Any idea what could be wrong ??

When I load the official Garmin Map it routes perfectly
(Course 105.5" true
Distance 522 km)

Info from the OSM Map: OSM_generic_routable (DEU_06_08_2018)
Course: 98.5 " true
Distance 419km

Thx in advance

Edit: Maps - Global Maps is not the active Map (I checked and double checked :smiley:
Edit 2: The Plot thickens When using Activity Profile ATV or Dirt Biking Cycling it routes correctly.
I tried to remove ALL "Road type … " and “Feature type avoidances” from one of the activities that didn’t route, But NO Luck !!

Try to set one or two intermediate points. Long distance routing often results in a direct line with these maps.

Thx Will try. Report back !!!

Now that works. Added 3 extra points and it routed me back and forth to Southern Germany before putting me back on track. :smiley:

But after adding 2 more points (so a total of 7 incl start and end) and the route worked !!

Thx for the Tip, appreciated

Hi ligfietser,

I’ve noticed that the site uses mkgmap r3972. I am not sure if that also means that the default style of this version is used.
If som it doesn’t contain some routing improvements, esp. the changes from r3979:

Thx Mike to report it back and to hear it works.
Gerd, yes it uses the default style that comes with the mkgmap version. I’ll have a look at the improvements for the generic new style because that map uses its own style.

I am using Garmin Basecamp 4.6.2 and the OSM map of Austria, when I try to create a route between two point (10km) using the “Driving” profile, the route is a straight line, if I switch to the “Motorcycle” profile it creates the route properly
Is there a setting that I need to change or is this an issue with Basecamp or a limitation of the Openstreet maps.

I think I have found out what is going on, my destination point was about 65M from a routable road, when I moved the point to about 35M from a road, the automatic routing was then able to find a route along the roads and via foot paths. I would assume that there must be some sort of logic in Basecamp that decides that there is no route once it get far enough from a routable roadway.