No place names in OSM Map on an Etrex

Hi everybody,

Recently I loaded some OSM maps on my Etrex (Venture Cx), and it turns out that place names are never shown on the screen, independant of zoom and map settings. I downloaded these maps via (thanks a lot to the creators by the way, very useful!), and I directly downloaded the GMAPSUPP.IMG files which I simply copied to the Etrex. The place names DO appear on the OSM maps themselves, so it seems thay’re simply not being rendered in my unit.

(In case it makes a difference: I used some Austria Alps region and Morroco, and both give the same ‘error’)

What am I doing wrong? Should I use another TYP file?



The typ file is only included if you select a country from the pulldownlists and you selected the Mapnik typ as well, custom maps (where you added or removed tiles from the selection manually) can’t have the Mapnik typ file included at this moment.

It appears that you included a Mapnik TYP file in your request? If so, can you try again without?

No, I did not include the TYP file. I only selected 2 tiles: centre and east Marroco.

As the place names didn’t appear I tried to add this TYP file later, by means of GMapTool, but I didn’t manage.

Should I be able to see place names at any zoom level?

If it is of any help, I’ll include the ‘INFO’ data that GMapTool reads in the GMAPSUPP.IMG file:


Reading file C:/Garmin/Topo Maroc/Maroc Roads/gmapsupp.img.

File: C:/Garmin/Topo Maroc/Maroc Roads/gmapsupp.img, length 9041408
Header: 23.05.2011 13:01:40, DSKIMG, XOR 00, V 0.00, Ms 0
Mapset: OSM World Routable

Map length s-f CP prio PID FID name
63240548 MPC 4313284 5 1252 25 3 2000 OSM World Routable
63241052 MPC 4681216 5 1252 25 3 2000 OSM World Routable

Data MPS
F: PID 3, FID 2000, OSM World Routable
V: OSM map set (0)



Any idea?

Alvast bedankt!!

I did some new tests, and finally managed to use the modified TYP file. However, apart from different colors and wider streets (doesn’t make sense on the Etrex) nothing changed, the problem persists.

However, I do see that not only the map doesn’t display place names, there’s also some other errors/phenomenon:

  • The see is not blue, but has the same (yellow) color as the land. The line that limits the land from the see is thin blue and the cursos says ‘line’
  • Street names (highway names) are very prominent, and on a zoom level of let’s say “8 km” is the only visible label

And, what could be of importance (no idea…) is that my unit is from the USA and only has the ‘Americas Marine Point Basemap, jan 2001’ as a base map, I guess european unit are different.


I don’t have a clue yet about the placenames, but regarding the sea I can tell that there is no sea :slight_smile:

Seapolygons are not very mature yet (they tend to flood the land), however there is a special Mkgmap branch that should improve this. I intend to release a version in the near future that includes seapolygons (but I need the 3rd server for that, as the other two are too busy).

Obviously in the Alps there’s not much sea, but I was doing the tests on the Marocco map, as this is a much smaller file (only 8 MB) and loads quickly on the Etrex.

Anyway, I will try to get a unit of any of my cycling friends and do the test with that one, that will at least show if the problem is in the unit or in the map.

Thanks for helping so far!

I have a Venture Cx with American basemap myself and it should show the place names etc very well. Please try my openfietsmap to test it. It should show all the details. If you want a slightly smaller map try my Greece map at
I think there must be something switched off in your Etrex settings. Did you put on the declutter? Try to turn it off. Have you switched off the map points? You can set this up in the map settings of your unit.

In the end I did a hard reset (some ‘secret’ button combination) and after that place names are shown as required. The reset must have changed a parameter that provoced the not showing the place names, but I don’t know which parameter. Now the ‘declutter’ parameter indeed does make a difference.

The question of the sea appearing blue or yellow still depends on the zoom setting; at 200km it shows the “basemap” and the sea is blue, below that it takes the OSM map (“mapsource” is indicated") and the sea changes yellow. A minor issue.

Problem solved!