No data found in this area.

Hello, this appears to me when I try to download an area on josm: “No data found in this area”. Anywhere I select to download gives me that error.
I have Kubuntu 19.04 and the tested version of josm.
Anyone can help me? Thanks.

Ive had that happen recently also. What worked for me was to go to File > Update Data, and everything worked as it usually does. Hope that helps!


It didn’t work. Still appears the same error. Thanks anyway

Try File > Download Data
From then pulldown menu?

hmmm …

Can you give an example of where you’re having this issue? Is it possible that there aren’t any nodes in that area, just the middle of some long ways? In such a case, the way won’t be found and you can get this message.

It’s on my city, and there are a lot of nodes, streets, parks, etc. But I started a virtual machine with Windows and it works just fine. So I am gonna use it there. Thanks for answering.

I just had the same problem. For me the issue was that in the File > Download Data menu the Download from Overpass API tab was activated. After switching to Download from OSM it worked. Maybe the UX could be improved here.