New A421 routing funny

I drove along the new A421 Bedford southern bypass road in the UK recently. This dual carriageway road only opened in Dec 2010, and was swiftly mapped and put onto OSM. It includes way ids 90843373 and 90843384 amongst others. The track appears accurate, and it displayed OK on my Garmin Etrex Legend Hcx, but my GPS refused to route me along this road, either outbound or on the return journey. Even when I was on it and hit “recalculate route”, it still generated me a route going across open fields, not down the new road. It seemed not to recognise the track as a road at all.

I’ve eyeballed the raw OSM data, and it looks OK to me, but I’m not a developer and I know nothing about what attributes are necessary to make ways routable. The map loaded into my GPS was built on Lambertus’s server around 27 Dec 2010, so it’s possible that if there was a problem with the initial data entry then it has been fixed now. But if not, somebody more knowledgeable than me might care to take a look sometime.

Apologies if this is posted in the wrong place.

You can try a newer map and see if someone fixed it between the time your map was generated and the time you checked it for errors.

There are two obvious options if the problem is still there:

  • The tagging is not ok
  • The geometry is not ok. I.e. there is a (possibly very tiny due to unconnected nodes) gap in the road.

I’ve just had a look at some of that area. Keepright was showing some almost junctions, and unconnected ways etc. These would cause problems with routing. I’ve just fixed a few of the obvious ones, so hopefully it should improve things in the next version of the Garmin maps.
Though there’s plenty of other errors and strange tagging in that area, most of it probably needs to be checked on the ground. See
There’s some strange refs / names on the link roads, and they should probably be tagged as trunk_link, not trunk.

I don’t live very close to this area, unfortunately. It’s on a journey I make approx. once a month, and I don’t have much time to stop and do surveying when I do go. But I will keep checking with updated maps when I can.

I wasn’t aware of keepright. (Is there any doc for it? I found this page: but it doesn’t give an idiot’s how to use guide. Can it be run as a stand-alone tool? Is putting somewhat cryptic ?parameters on the URL the only way to specify an area of interest for it?) I tried Vclaw’s link to “Edit in Potlatch”, but nothing I could identify as error markers appeared on the display.

PS - the keepright thing was my mistake - I have a script blocker enabled by default on my web browser, and I failed to give scripts from permission to run. Once I do, I can see both the map and markers, and all becomes clear.