namibia maps working?

i downloaded the namibia map and wanted to pre-load all my destinations. when i went to search for my first one, the easiest one being a hotel in the capital city, it couldn’t find the road. when i tried doing a search for the hotel name it said that there were no hotels loaded into the file. i double-checked and the map is correctly installed on my sd card. i changed the country to namibia and it found the city but that seems to be it.

additionally, when i try to enter the gps coordinates for another hotel:


-24.805500, 18.188778

it won’t even let me enter the full coordinates. it won’t let me put in the last 0 in the latitude and it won’t let me enter the 8 for the longitude. i got these coordinates from google maps on the hotel’s website.

has anyone else used the namibia map? has anyone else had success?

thanks so much.


isn’t this a restriction of your device ? I fail to see how this can be influenced by the installed maps.

Did you try to look for the hotels on ? Are they visible on that map? If not, they will not be included in the file you downloaded. If they are on, it is still possible that the process to generate the map you downloaded is incorrect or contains out-of-date data.

It would also be good to know from where you downloaded the map. There are several providers that offer OpenStreetMap-based maps for Garmin, each having their own process and update frequency.

thanks for your reply.

i’m honestly not sure why the device wouldn’t recognize the coordinates. i’m not a star user so i figured the coordinates had to correspond with an area on an installed map. and when the numbers couldn’t be entered, i assumed it was because the device had no map that corresponded with the coordinates. am i wrong in that thinking?

to make things more difficult, i found another set of supposed coordinates online that also cannot be entered. 24.8059° S, 18.1894° E

i didn’t try searching for the hotel, but i just tried now and the hotel’s street name and hotel’s name both came up on i searched the gps again and still nothing.

i downloaded the maps from do you have any other sites you’d recommend instead?

thanks so much again.


On all Garmins you can set the format of coordinates, I suspect you are using the wrong settings.
An example of the formats you can choose:

Degrees, minutes, and seconds (DMS): 41°24’12.2"N 2°10’26.5"E
Degrees and decimal minutes (DMM): 41 24.2028, 2 10.4418
Decimal degrees (DD): 41.40338, 2.17403

Edit: deleted as likely not helpful and/or not able to enter as suggested on some gps models.

Your map seems to support address search. What address is missing?
I have never seen a message like “no hotels loaded into the file” on Garmin GPS. Are you really using a Garmin device?

thanks to all for trying to help. i’ve tried changing the format of the coordinates. i’ve tried entering the numbers all three ways and i’m unable to enter all the numbers using any format.

i’ve tried multiple addresses and each time i enter it it says “no matches found.” i’ve limited the search to namibia only (i have several maps loaded on my device) so as not to enter the incorrect city somehow. i’ve tried it with multiple hotels. knowing that sometimes hotels are located in out of the way places that may not be on the map, i just tried the us embassy in windhoek. the device still shows “no matches found.”

i’m using the garmin nuvi 1450.

has anyone else tried to load the map file onto their device and been successful in entering an address?

for what it’s worth, i used the same process with the namibia map as i did with the brazil map and had no problem.


You don’t have to enter all those digits. With three decimals you should be able find this address on any Garmin device:

Map of Namibia in GPS:

Address search:

Position format: