My waypoints don't appear in Potlatch

I converted a Garmin GPM file to GPX using GPSBabel and selected the “include waypoints” option in GPSBabel prior to conversion. I then uploaded the file, got a confirmation that the upload had been successful, went to the Potlatch Edit page and hit ‘g’ and there were my GPS tracks. However, the waypoints were not visible and nowhere in the various instructions could I find an equivalent to ‘g’ to display the waypoints. I could, of course, have gone around the keyboard trying all the letters but was afraid that in doing so I might delete the whole OSM database or do something equally disastrous (e.g. hit ‘a’ for ‘Armageddon’).

How do I reveal the waypoints in Potlatch ?



I have a feeling that you should take another way when you start editing. Open first the GPS traces tab on the main page, select your track and press Edit there. Now Potlatch starts with an extra option which can trace and waypoints into locked ways and POIs. Now you need to find your waypoints and free the locking. I am not totally sure if this is exactly how it goes, though.

I’m afraid that didn’t work, but thanks for the suggestion. It simply covered all the ways (which I had already edited) with my tracks in red. There was no sign of the waypoints and no sign of any facility for unlocking them.

I just hope that those red tracks which covered all my ways have not been written to the database because if they have then my work of the last few days has been ruined.


Open the GPX file you uploaded and use the find function to search for WPT. Soo you can see that you really have waypoints in there.

I have no idea what you mean with red tracks, could you describe little more perhaps?

Are you sure that your waypoints are not in Potlatch? You cannot see them apart from the real existing waypoints because they look just the same, green dots. You must select a point before you can see if it is is an unlocked POI. I must say that I do not consider it as a good tool for importing POIs even it works somehow. Therefore I have only tried it once.
EMJ, red tracks are GPS tracks which are converted automatically by Potlatch to temporary ways. They must be unlocked manually, so pacman need not to be afraid, they are not written to database before accepting they manually.

Afaik, waypoints aren’t imported in the database. However if you load them directly in potlatch or JOSM they will appear. Opening traces directly with potlatch goes by clicking on the edit link next to your trace. So press here on edit, you will get here Also if you ever get stuck waiting in the queue, you can click on ‘edit’ and it will load directly.

Sorry, I’m a beginner here and need a leg up. What do I open the GPX file with so that I can get at the Find function ? . I went to “Your GPS traces” but the file in question only offers “More”, “Map”, “Edit” and the “Edit” simply draws the map so that I can edit it. I can’t find a file reader that allows me to open the GPX file and read the content directly.

The red tracks are the GPS tracks that appear when I choose the option “Track: convert your GPS tracks to locked ways for editing”.

No, there are no green dots where my waypoints should be.

And thanks very much indeed for the assurance (“They must be unlocked manually, so pacman need not to be afraid, they are not written to database before accepting them manually”).


I like the idea of A for Armageddon… might implement that.

There should certainly be green dots at your waypoints if you start Potlatch by clicking the ‘Edit’ link by the trace, then click ‘Track’. But assuming that you’re talking about , you don’t actually have any waypoints in the file - I downloaded it, opened with a text editor, and checked. I’d check your GPSbabel (or whatever) settings.

JRA - you’re right in that the locked waypoints should ideally be shown in red; this either requires a new movieclip (which complicates the object model) or a colour transform so I haven’t worked out how to do it yet. :frowning:

Thanks very much, Richard, for checking that for me and for the leg-up re. the text editor, i.e. that I can use a simple text editor to open GPX files.

SUCCESS: As you suggested, I’ve gone back and looked at the GPSBabel settings. My findings were a little curious. I re-converted my Garmin file into GPX but this time I specified in GPSBabel that only the waypoints should be converted (rather than waypoints and tracks). I checked the resulting file with a text editor and it contained nothing but waypoints (as expected). I then uploaded it and - bingo ! - there are my waypoints in Potlatch.

So it seems that if I ask GPSBabel to convert both waypoints and tracks, i.e. if I tick both boxes in GPSBabel, it only does the tracks. But if I ask it to just convert the waypoints it does so. So either there is a bug in GPSBabel or I used it incorrectly (but if it is the latter I’m clueless as to what I could have done wrong).


Hmm maybe you should file a bug report with GPSbabel on this, if you can reproduce it two times… :wink:

Sorry for being to terse about editing .gpx files,

It’s possible to see both waypoints and a GPS track in Potlatch, even if your waypoints are in a different file.

Before you upload the waypoint file you should make sure it has at least one trackpoint in it - the OSM server will reject it.

Then, to view two files at once, change the URL so that instead of (say) “gpx=87651”, it says “gpx=87651,98872”, where the numbers are the ids of the tracks you want included. You can have as many as you like, at least in theory!